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0.I Don’t Have Time to Read This Manual,
Give Me the Short Version!

OK. You have some reports that you need to get out right now. Here’s how to do it:

1. Install your GEOSYSTEM for Windows package: Insert the disk labeled “Data
Manager” into your disk drive, click on your Windows “Start” button, select Run then
type A:SETUP . When asked if you have any other software to install, insert any
other GEOSYSTEM for Windows disks.

2. After restarting your computer, click on the “Start” button, select Programs >
GEOSYTEM > GEOSYSTEM for Windows.

3. Select a place to store your data: this can be a directory on your computer or on
your network server. (If you want to store your data onto a network, you should read
Section 1.2 before proceeding.) Use the drive and directory selection boxes on the
left-hand side of the screen to browse to the directory where you want to store your
data.

4. Testing data is stored into different files based upon the project the test was
performed for: all of the data for project 2001-11a-14 goes into one file, all of the
data for project 2001-11a-15 goes into another. So, you need to create a new
project file for each project for which you have testing data: For the test that you’re
going to enter, in the Name box type a name for the file that will hold the data for
that test and all other tests in the same project.

⇒ The file name can be practically anything, although it’s handy to use the
project number.

After entering a name, click on the Open button and select Yes when asked if you
want to create the file.

5. Make sure that the dimensions listed in the lower-left corner of the screen match the
units you’ll be using for the project. If your measurements – dial readings, volumes,
sieve openings, etc. – are in feet and inches, you should see “Dimensions: US”; if
your measurements are in meters, centimeters and millimeters, you should see
“Dimensions: SI”. To change the setting, select Project > Dimension Units.

6. Within a project file, lab tests are stored into different folders depending upon where
the samples were taken from in the field: samples taken from boring B-1 go into a
source folder named B-1, samples from test pit TP-5 go into a folder named TP-5,
etc. The yellow box on the left side of the screen lists the folders already created for
the project.
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⇒ If you already have a folder created for your samples, click on it.

⇒ If you don’t know where your sample was originally taken from (for instance,
because the sample was submitted for testing by a client), click on the folder
labeled (no source).

⇒ If you don’t yet have a folder to hold samples from the same location as your
new sample, select Source > New: this opens a new window on the right
side of the screen. Begin by entering the name of your material’s location
(i.e., the boring number from which the sample was taken) into the Source
data entry field.

7. Next you need to tell the system something about the soil sample on which you’ve
run the lab test. At the right side of the screen are a series of numbered cards
(called sample cards): find a blank one and enter your sample’s number, description,
etc.

8. Now it’s time to enter the testing data. At the bottom of the card you just filled in
you’ll find one or more underlined words (GRN-SIZE, PROCTOR, etc.): these are
links to the screens where you enter your lab testing data. Click on the link for the
testing module that you need: make sure that the link on which you click is at the
bottom of the same sample card that you just filled in.

⇒ For further instructions, consult the manuals for each lab testing module.
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1.Introduction, Installation and Setup

The GEOSYSTEM for Windows family of laboratory software modules use a common
interface that handles the details of storing and retrieving data. Because data for all of the
GEOYSTEM for Windows modules are stored in a common directory (called a project), results
from one laboratory test can be included in the calculations for another test.

⇒ As an example, the USCS Classification module utilizes the diameter
percentages (D60, D30 and D10) calculated by the Grain Size Distribution
module, along with the Atterberg limits (PL, LL and PI) calculated by the
LIMITS module in its calculation of a USCS classification.

⇒ GEOSYSTEM for Windows modules are individually licensed so, for
example, if you don’t perform many CBR tests, you don’t need to purchase
the CBR module.

The common data file interface is called the GEOSYSTEM Data Manager (GDM): this is
the program that starts up when you click on the GEOSYSTEM for Windows shortcut on your
desktop. This manual covers GDM version 2.0.

1.1 Hardware and Software Requirements

GEOSYSTEM for Windows has currently been tested to run under Windows95,
Windows NT 4, Windows 98, Windows ME and Windows 2000.

Note: Prior to installing GEOSYSTEM for Windows, please visit Microsoft’s web
site (http://www.microsoft.com) and download the latest Service Pack for your
operating system.

⇒ Although GEOSYSTEM for Windows will run on a 486, a Pentium 300 or
faster or equivalent CPU (e.g., AMD Athlon) is recommended. At a
minimum, 16 megabytes of computer memory is required; however, due to
Windows own memory usage, the software will run much more efficiently on
a computer with 32 megabytes of memory. Windows NT 4 and
Windows2000 users should have a minimum of 64 megabytes, with 128
megabytes recommended
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⇒ Windows is designed so that as the computer uses up its memory for
storage, the excess is swapped to the hard disk -- because of this,
GEOSYSTEM for Windows will require some free hard disk space to be
available at all times. The program’s requirements will vary, however, a
good rule of thumb would be to leave at least 60 megabytes of space free on
the computer’s local hard disk.

⇒ A minimum display resolution of 800x600 at 256 colors is required. The
laboratory testing software utilizes very complex data entry screens that are
difficult to adequately display in low resolution.

Many computer users are not aware that their computer’s display has different
resolutions and may be running in the low-resolution 640x480 mode by default. Follow the steps
below to check your display resolution.

To check the system display resolution:
1. Click on the Start button then select Settings > Control Panel.

2. Click on the Display button.

3. Click on the Settings tab.

4. If the Desktop area slider reads “640 by 480 pixels” try dragging the slider to the
right: If you have a 17 inch (43 cm.) or larger monitor, try the “1024 by 768 pixels”
setting; for a smaller monitor, try the “800 by 600 pixels” setting.

5. If the slider doesn’t drag and you are running a desktop machine, check to see if you
have the correct monitor selected: Click on the Change Display Type button.
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1.2 Network Installations

GEOSYSTEM for Windows works well both storing to and running from a network drive.
Please note, however, that the software is not network-aware. What this means is that there
isn’t any network-specific code in the program: it’s your network’s responsibility to route data and
printouts from your local computer to a network destination.

⇒ GEOSYSTEM for Windows does not understand file paths such as
\\server\geosys . To install the software onto a network drive you must first
use the Windows Explorer program to map the network to a drive letter:
Make sure to select the option to reconnect to the mapped network
drive at logon . When you install the software, install onto the mapped
network drive. Similarly, if you want to store your data onto a network, you
will need to do so through a mapped drive.

⇒ If you install the software onto a network drive, it can be accessed from any
computer attached to the network. On each machine that accesses the
software (i.e., client machines), several files will be automatically installed
into the Windows SYSTEM directory: if you’re running NT4 or Windows
2000 on the client machine, the first time that you start the software on the
client you need to be logged in under an administrative account; otherwise,
the appropriate files cannot be copied into the SYSTEM directory and the
software may not operate correctly.

⇒ Wherever the program is installed, write, rename, modify, create and delete
access into the program’s installation directory must be granted to all users.
GEOSYSTEM Software will not provide technical support for a program that
has been “locked down” with limited user rights or disk quotas.

⇒ Dial-up or wide-area network installations are not permitted by our license
agreement. Chapter 5 covers this and other licensing issues in detail.

⇒ Using GEOSYSTEM for Windows on a network is not without attendant
risks. Bad network cards, misconfigured servers, damaged cables, crashed
routers, buggy operating systems, etc. can cause data loss. If you
experience problems saving your data to a network drive, please refer to our
tech. note at http://www.geosystemsoftware.com/gdmfprob.htm
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1.3 GEOSYSTEM for Windows and LD4

LD4 (our Windows Drilling Log package) and the laboratory modules utilize the same file
manager software (GDM, the GEOSYSTEM for Windows Data Manager). If you have licensed
LD4 you don’t need to install a separate Data Manager disk, and all laboratory modules should
be installed into the same hard disk subdirectory as LD4.

If you prefer for LD4 to be installed on a different set of computers than the laboratory
modules, both installations can access the same set of project files: LD4 can read files created
by the laboratory modules, and vice versa.

⇒ LD4 does provide one advantage over laboratory module-only installations:
LD4 allows multiple users to access the same project file simultaneously.

1.4 Upgrading from GDM version 1

GDM 2.0 is fully compatible with files created by GDM 1.x (the original Data Manager
program first shipped in 1996). Please note that the reverse isn’t true: projects created with
version 2.0 cannot be read by the older program, so plan your upgrade so that all GEOSYSTEM
for Windows installations have the new version before you start entering data.
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1.5 Installing the Software

Caution: Even sitting on a shelf it’s quite possible for a floppy disk to become
unreadable. Since there is a charge for replacement disks after the first year,
you should make a duplicate of your disks before installing the package -- keep
the duplicates in a safe place (preferably off-site).

To install your software:

1. Insert the disk labeled “Data Manager” into a disk drive.

2. Click on the Windows “Start” button then select Run.

3. Type A:SETUP

4. During the install, if the software determines that you have an existing
GEOSYSTEM for Windows hard disk installation, it will suggest that you install into
that directory. It is strongly recommended that you do so.

⇒ The installer will not allow you to install into a hard disk subdirectory that
contains a copy of LD4: LD4 incorporates its own copy of the Data Manager
package.

⇒ If you are installing to a network drive, please review Section 1.2

5. When asked if you have any other software to install, insert any GEOSYSTEM for
Windows laboratory module disks that you have licensed.
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1.6 Starting GEOSYSTEM for Windows

There are a number of ways to start the software:

⇒ If, during installation, you selected the option to add a shortcut to your
desktop, you can start the GEOSYSTEM for Windows package by double-
clicking on the “GEOSYSTEM for Windows” icon on your desktop.

⇒ Click on the “Start” button, select Programs > GEOSYTEM > GEOSYSTEM
for Windows.

⇒ If you’re running the program from a network installation you can start the
program by using Explorer to navigate to the directory where the software
has been installed (remember! you must use a mapped drive) then double-
click on the file called GDM.EXE. (You can make a shortcut to this file by
dragging the file -- with the right mouse button down – to your desktop.)

If you don’t have a desktop shortcut for starting the software, you can add one by
following the directions given below:

1. Open up your Windows Explorer, “My Computer” or “Network Neighborhood”
program and navigate to the subdirectory where you’ve installed the software.

2. Shrink the size of the file window so it doesn’t cover the whole screen: you need to
be able to see a portion of your desktop in the background.

3. Within the directory you will find a file called “GDM.EXE”: right click on that file and,
while holding the right mouse button down, drag the file over to your desktop.
Release the mouse button. Windows should show a menu of possible actions:
select “Create Shortcut Here”.
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1.7 Configuring the Software

GEOSYSTEM for Windows has a few configuration options that should be set up the
first time the program is started: do this by selecting Options > Setup General Options. The
program’s Setup dialog is shown below:

Figure 1.7.1 -- Setup Dialog

⇒ On reports, “Figure No.” is titled : Many report formats used by the
GEOSYSTEM for Windows laboratory testing modules feature an area to
place a figure number; next to the actual figure number, an identifying title is
placed. This prompt allows the user to rename the title from "Figure
Number" to "Plate:", "Page:", or anything else desired.

Tip: You can use the "Figure Number" prompt to add an additional field to
your test reports -- for example, if you'd like to have a report date on each
report, change the "Figure Number" title to "Report Date", then enter your
report date when the test module asks for the report's figure number.
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⇒ Report (GRN-SIZE data, PROCTOR data, CONS data) to : Originally, these
older laboratory testing modules shared a common setting when it came to
reporting percentages: a PROCTOR compaction percentage was reported
to the same number of decimal places as a GRN-SIZE percent passing
value. As a way to partially correct this without requiring an update to
laboratory testing modules themselves, the software allows selection of the
number of decimal places used in percentage reporting on a module by
module basis. Note that this still affects all percentages reported by the
module: for example, if "1 decimal place" is selected for the CONS module,
both the natural moisture percentages and the swell/collapse percentages
calculated by the program will be reported to 1 decimal place. Future
upgrades to the lab. modules themselves will address this issue.

⇒ Report percentages to : This setting is only used by lab. modules that don't
support any other method of specifying the number of decimal places to be
used when reporting percentage data. See the previous paragraph.

⇒ Report Atterberg limits to : Atterberg limits entered by the user into the
laboratory modules are automatically rounded to the number of decimal
places chosen here.

⇒ Include "Location" prompt on all source tables : This option is provided
for compatibility with versions 1.x of the GEOSYSTEM Data Manager
program. Normally each sample entered into the "No Source" folder includes
a prompt for the sample's "Location" while data entry screens for borings,
test pits, etc. don't since the boring number serves to identify the sample's
location. The older Data Manager included a "Location" field for every
sample, regardless of whether or not the sample was also associated with a
particular boring -- the Include Location... prompt allows you to work with
projects that have been created with the older program.

This setting is not recommended for new installations. Please note that if
you select this option and enter data into the Location prompt, your
laboratory testing reports will not show the sample number, sample depth or
sample source.
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2.Entering Data

LD4 stores data on a project-by-project basis: Data for all of the borings, test pits and
trenches taken in a single project are stored in a single project file. Project files may be stored
on hard disks, removable floppy disks and network drives.

Each project file is divided into folders called sources. Each source stores the data --
sample names, depths and laboratory testing information -- collected at a particular physical
location such as a boring, test pit, stockpile location, etc. Each source is given a unique name
such as “Boring B-1”.

Additionally, project files include a section for data relevant to the project as a whole
(such as the project number and the client’s name) called the Project Data section.

The figure below illustrates the structure of a typical project file:

Figure 1.7.1 -- Typical Project File

⇒ Figure 1.7.1 includes four sources: “Boring B-1”, “Boring B-2”, “Test Pit TP-
1” and “Stockpile”.

⇒ The project depicted was entered by a company with licenses for the Grain
Size Distribution, Atterberg Limits, California Bearing Ratio and Drilling Log
(LD4) modules. If you haven’t licensed, for example, the Grain Size module,
you won’t be able to enter grain size distribution data.
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2.1 Creating a New Project

To create a new project:
1. If you’re already editing a project choose Project >New.

2. Make sure that the current directory is the one where you want to place your new
project -- the first name shown in the file listing (next to the open folder icon) is the
current directory.

3. At the Name prompt type in a name for your new project.

⇒ Project names may be up to 254 characters long and may include spaces,
but they may not include any of the characters shown inside the following
quotes: ":.*?\".

⇒ There is a limitation on how deep within a directory structure you delve when
creating a new project. If you get a “file not found” message from the
software when trying to create a project in a directory such as
“G:\projects\engineering\geotechnical\2001\march completion\southwest”

you’ll need to shorten the path.

4. At the Description prompt type in a short description for your project. The project’s
description is shown just below it’s name in the program’s file dialogs – it’s mainly a
holdover from the days when filenames could only be eight characters long (the
description was used to provide a longer reference to the file’s contents). If desired,
you can ignore the prompt.

5. Click on the OK button.

2.1.1 Project Measurement Units

There is a single basic measurement selection that must be made for every project:
“US” or “SI” units.

⇒ “US” units means that testing measurements (Proctor mold volumes, sieve
opening sizes, Swell/consolidation dial readings, etc.) and sampling lengths
were taken in inches.

⇒ “SI” means that testing measurements were taken in centimeters or
millimeters, depending upon the testing module.

Once you’ve created a project the units attached to the project are shown in the lower-
right corner of the screen and will say either “Dimensions: US” or “Dimensions: SI”.
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If the wrong units were selected:
1. Choose Project > Dimension Units. This displays the Project File Dimension Units

dialog, (shown below).

Figure 2.1.1 -- Project File Dimension Units Dialog

2. Select the appropriate units for the project.

2.2 Opening an Existing Project

To open an existing project:
1. If you’re already editing a project choose Project >Open.

2. Change to the directory where your project is located -- the first name shown in the
file listing (next to the open folder icon) is the current directory.

3. In the file listing GEOSYSTEM for Windows projects are shown next to an icon.
Double-click on a project to open it.
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2.3 Data Entry – Background Information

The figure below shows a typical GEOSYSTEM for Windows edit screen:

Figure 2.3.1 – Edit Screen

If you’ve used a Windows word processor such as WordPerfect then you have the basic
idea of how GEOSYSTEM for Windows handles data entry; the following sections cover some
specific issues.

2.3.1 Important Menu Selections

Project
New: See Section 2.1

Open: See Section 2.2

Save: Saves the current project
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Sort On: Sorts the list of sources shown in the yellow box on the left-hand side of
the screen. Doesn’t affect any printouts.

Find Text, Replace Text, Find/Replace Again: Searches for and optionally changes
text entered into sample cards (i.e., sample numbers, depths and material
descriptions). Does not replace text entered into one of the lab. module prompts
(e.g., D60 in the USCS module).

⇒ Refer to Section 3.2 if you need to search for text within multiple project
files.

Exit: Saves all changes and exits. Note: there is no “Abort without saving changes”
option.

Source
New: See Section 2.5.1

Duplicate: See Section 2.5.1

Delete: See Section 2.9.

Sort by Depth: This sorts the current source’s sample cards in order of increasing
sampling depth.

Edit
The Edit menu contains the standard Undo, Redo, Cut, Copy, Paste and Delete

commands; in addition to:

Underline: Toggles a marked section of text between underlined and not underlined

Insert Card, Cut Card, Copy Card, Paste Card: See Section 2.10

Print
Printer Setup: Displays the standard Windows Printer Setup dialog.

There will also be a “Print” entry for each installed laboratory testing module
licensed.
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Tools
The Tools menu shows any plugin utilities that have been added to the system such as

the envelope printer, the Swell/Consolidation module’s DOS-to-Windows file conversion utility,
etc. (To get help on a specific plugin, start the utility and use the utility’s Help option.)

Options
Setup General Options: See Section 1.7.

Additional “Setup” entries will be available for most licensed laboratory testing
modules. Refer to each module’s reference guide for setup information.

2.3.2 Moving Around the Screen - Useful Keystrokes

You will find the following keystrokes useful while entering data:

Keystroke What it Does

Tab Changes to the next data entry field

Shift-Tab Changes to the previous data entry field

Shift+Up/Down/Left or
Right Cursor Keys

Marks text

F7 Toggles a marked section of text between underlined
and not underlined

Ctrl-Down Arrow, Ctrl-Up
Arrow

Jumps to the next and previous sample cards.

Figure 2.3.2 -- Useful Keystrokes

2.3.3 Paragraph Fields

When entering data for multi-line text items, do not press the Enter key unless a line
break is actually desired: When the right-hand edge of the data entry field is reached, the
program will automatically wrap the text being typed onto the next line. If a line break is desired,
pressing Enter will produce one - the line before the break will have a “¶“ at the end.

The rationale behind only pressing Enter when a line break is actually desired is
because the width available to print a particular paragraph item varies from one report format to
another; the program must reformat the user’s text to fit the space available on the report,
choosing its own linebreaks as necessary to fit the width allocated for the item. For example, the
following data entry field
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may be reformatted to

or

depending upon the width available for printing the field on the hardcopy report. Note that the
linebreak after the word “after” appears in both examples -- this is because the user pressed
Enter after typing “after” in the data entry field (again, you can tell because of the “¶” shown in
the data entry field).

2.3.4 Subscripting and Superscripting

You can superscript a character in any data entry field by prefixing the character with the
“‘” symbol. For example,

kg/m`3
when printed on a report will show up as

kg/m3

Likewise, characters may be subscripted by prefixing each subscripted character with
the “~” character. As an example,

C~v
when printed on a report will show up as

CV

2.4 General Project Information

Note: See Section 2.3 for a general discussion of the data entry facility,
including menu selections, keyboard shortcuts and data entry techniques.
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After creating a new project the first thing you will want to do is to enter information
about the project itself, such as the project name and number. Do this by clicking on the
“Project Data” entry in the yellow box on the left side of the screen.
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2.5 Material Sources

Note: See Section 2.3 for a general discussion of the data entry facility,
including menu selections, keyboard shortcuts and data entry techniques.

All of the testing and sampling data taken from a single material source are grouped
together within a single source folder. (Sources represent physical locations from the project --
some different types of sources are: borings, test pits, monitoring wells, trenches.)

⇒ Source folders aren’t always associated with subsurface explorations:
stockpiles, for example, can be considered a material source if you’re using
the add-on Grain Size Distribution test module to plot particle-size curves for
samples taken from a series of stockpiles.

2.5.1 Starting Out: Creating a Source Folder

Once you’ve created a new project file and entered your project data the next step is to
open up a source folder: This is where you’ll be placing all of the data taken from a single
material source such as a boring, test pit, etc. To do this, select Source > New. You can also
copy the entire contents of an existing source folder by selecting Source > Duplicate.

Note: Laboratory testing data entered with a GEOSYSTEM for Windows module
such as GRN-SIZE is not copied when you select Source > Duplicate, however,
the calculated final results (such as GRN-SIZE’s “percent < #200” value are).

If you can’t identify your testing sample’s source (perhaps the sample was submitted for
testing by a client) you won’t be making a new source folder: all GEOSYSTEM for Windows
projects have a special folder just for entering data for samples that weren’t taken from an
identifiable source called the (no source) folder.

⇒ The (no source) folder is a part of every GEOSYSTEM for Windows project,
and can’t be deleted.

To enter testing data for a sample that is not from an identifiable source, click on the (no
source) entry in the yellow panel on the left side of the display.
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2.6 Entering Information about the Test Sample

Before entering your testing data, you’ll need to tell the software some basic
identification information about the sample being tested. After you’ve opened the appropriate
source folder for the sample you should see a display like the one shown in Figure 2.3.1: the
right side of the display, where the numbered rows are shown, is where you’ll be entering your
sample data. The rows are called sample cards – find a blank card and enter your sample’s
identification information. The package supports the following identifying fields: sample
number , elevation or depth , sample length and material description .

⇒ Sampling lengths are assumed to be in either inches or centimeters,
depending upon the measurement units chosen for the project (see Section
2.1.1).

⇒ The sample’s identifying information is printed by the laboratory modules on
all hardcopy reports.

2.7 Entering Testing Data

After creating/opening a source folder and entering the sample’s identification
information, you can proceed to enter the actual testing information. At the bottom of the
sample card holding your sample’s identification you can find one or more underlined words:
these are links to the testing modules that you have licensed. Click on the module for the test
data to be entered; a key to the module names is shown on the following page:
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Name Module

AASHTO AASHTO M 145 Soil Classification

CBR California Bearing Ratio

CONS Swell/Consolidation

GRN-SIZE Grain Size Distribution

LIMITS Atterberg Limits (PL, LL, PI)

PROCTO
R

Moisture-Density Test

R-VALUE Resistance R-value

USCS ASTM D 2487 (USCS) Soil
Classification

Table 2.7.1 -- GEOSYSTEM for Windows Lab. Module Names

2.8 Deleting Testing Data

If you want to delete the testing data entered into a particular laboratory testing module
for a given sample, right-click on the module link at the bottom of the sample’s card (see the
previous section) then select Delete xxxx Data (“xxxx” is the name of the lab. module).
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2.9 Opening or Deleting a Source Folder

To open an existing source folder:
1. Click on the source’s name in the list of sources entered into your project (this list is

in the panel on the left side of screen -- see Figure 2.3.1).

To delete an existing source folder:
1. Follow the instructions (given above) for opening the source folder that is to be

deleted.

2. Choose Source > Delete.

2.10 Deleting Samples

In addition to the standard Windows cut/copy/paste functions which operate on a single
data entry field at a time the software also supports deleting and copying/pasting entire samples.

To cut (i.e., copy to the clipboard then delete) one or more samples:
1. Data for each sample is entered into individual sample cards: to cut the data for a

sample, click on the number of the sample’s card (the number is shown jutting out
from the left side of the card).

2. If you want to cut data for more than one sample, continue clicking on the card
numbers for the other samples to be removed. You must click on the card
numbers in sequential order .

3. When all of the cards to be cut are highlighted, choose Edit > Cut Card.

2.11 Moving Samples Between Source Folders

Occasionally you may enter a sample’s data into the wrong source folder. To move the
sample – including all testing data – into a different folder, follow these instructions:

1. Open the source folder holding the card(s) to be moved.

2. Follow the directions for cutting sample cards given in the previous section.

3. Open the source folder where the card(s) are to be placed.

4. Click on the number of a card: the cards you are moving will be inserted above that
card.

5. Choose Edit > Paste Card.



Data Manager User’s Guide

=OP

3.Working with Project Files

The following sections provide information on finding, copying, moving and deleting
GEOSYSTEM for Windows project files.

⇒ If you need to move your entire program installation to a new machine, use
DOS to backup *.?DT, *.DAT and *.INI from the old machine’s
GEOSYSTEM directory to the new machine’s GEOSYSTEM directory.

3.1 Archiving Project Data Files

To save a copy of a project to a floppy disk for archival purposes:
1. Re-start or start the program: Archiving may only be performed from GEOSYSTEM

for Windows’ opening screen.

2. Click (once) on the project to be archived.

3. Click on the Archive button: This displays the Archive Options dialog (shown below).

Figure 3.1.1 -- Archive Options Dialog

4. Delete the original after completing the archive : Selecting this option deletes the
original project after archiving is complete. If anything goes wrong during the
archival procedure (such as a full floppy disk) the program will not remove the
original.
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3.2 Searching for Projects

Although GDM can only search for text in a single project file at a time, you can use
Windows 95/98/2000/NT’s “Find” facility to search through multiple project files for some text:

To search for text in multiple project files:
1. Click on the Windows “Start” button.

2. Choose Find > Files or Folders.

3. At the Named prompt, enter *.$P$
(The “*.$P$” tells Windows to look in the files where the GEOSYSTEM for Windows
package is storing your data.)

4. At the Look in prompt choose the hard disk where you’ve stored your projects.

5. Make sure to click on Include subfolders .

6. Click on the Advanced tab.

7. In the Containing text field, type in the text that you want to find.

8. Click on the Find Now button.

9. Windows will list any project files where it has found your text, followed by “.GEO”.
Start GEOSYSTEM for Windows and type in the directory and file name that was
found, without the “.GEO”.

⇒ Note: Windows will not find data that you have entered into one of the
GEOSYSTEM for Windows laboratory testing modules, or text that you have
entered as underlined.
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You can also use Windows’ search facility to locate a project file:

1. Click on the Windows “Start” button.

2. Choose Find > Files or Folders.

3. At the Named prompt, enter the name of your project, followed by .GEO. For
example, if your project is called “P31923”, you would enter P31923.GEO.

4. At the Look in prompt choose the hard disk where you’ve stored your projects.

5. Make sure to click on Include subfolders.

6. Click on the Find Now button.

7. Windows will list any project files where it has found your text, followed by “.GEO”.
Start GEOSYSTEM for Windows and type in the directory and file name that was
found, without the “.GEO”.

3.3 Using Windows to Move or Delete Projects

You can use Windows 95/98/NT’s Explorer program to copy or move your project files.
Using Explorer to look at your data file directory, you can find folders that have the names you’ve
given to your projects, with a “.GEO” extension. (For example, if you’ve named your project
BERTHOUD COUNTY LANDFILL then Explorer will show a folder named “BERTHOUD
COUNTY LANDFILL.GEO”. GEOSYSTEM for Windows keeps all of the “BERTHOUD COUNTY
LANDFILL” project data in that folder.) You can use drag-and-drop or the cut/copy/paste
Explorer options to delete or move the entire folder.

⇒ Note: While you can safely use Explorer to delete an entire project folder,
do not use Explorer to delete individual files within the project folder. Doing
so is guaranteed to render your project unusable.
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3.4 Compatibility with LD4

Files created with the GEOSYSTEM for Windows Data Manager program are
compatible with those created with the GEOSYSTEM LD4 Drilling Log package: you can use
LD4 to read laboratory testing project files, and you can use the Data Manager package to read
LD4 project files.

If you open an LD4 project with your GEOSYSTEM for Windows Data Manager
package, you will not see the same data entry screen as you would see from LD4 . This is
normal: the laboratory testing modules aren’t interested in sampler types, stratigraphy patterns
or transition intervals, so you’ll just be presented with sample cards requesting information about
testing samples (sample number, sample depth, etc.). Your drilling log data is still part of the
project – it just isn’t shown by the Data Manager package.
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4.Exporting and Summarizing Data

GEOSYSTEM for Windows includes a tool that allows the user to print simple lists of the
data entered into a project, and to export data to an ASCII file. (ASCII files may be imported by
word processing, database, spreadsheet and graphing programs.) The data summary and
export function allows the user to specify the information that will be exported or printed, and in
what order. In this way, lists may be created with only the data pertinent to a particular project.
The Data Summary and Export screen, accessed by selecting Tools > Data Summary and
Export, has the following appearance:

Figure 3.4.1 -- Data Summary and Export Screen

The following sections discuss individually the processes of creating a simple printed list
and creating a data export file.
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4.1 Creating a Printed List

A printed list is a report that is sent to the printer which uses the information specified in
a configuration file and the data stored in a given project file. Printed lists consist of a page title,
a heading section, which lists data common to the entire project such as the project name and
the clients name, the table section, which lists selected sampling and testing data, and an
optional footing section, which just includes a figure number chosen by the user.

An example printed list is shown below.

Figure 4.1.1 -- Sample Printed List

The first step in creating a printed list is to create a list configuration file, which is a set
of directions given to the software that determine what data to use when building the list.
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4.1.1 Creating a Configuration File

Create the configuration file by filling in the Title , Figure No. , Page Heading and Table
boxes, following the instructions given in the topics listed below.

Title

The text in this box will be printed at the top and center of the printout, and may include
whatever information is desired.

Page Heading

The heading section of the printout usually lists items that pertain to the entire project
being summarized, such as the client's name and the project number. (Data export files don't
require a page heading.) A short discussion of the Data Dictionary Box, which is used for
creating the page heading, is necessary before providing instructions on creating the page
heading.

The dictionary box, located on the left hand side of the list configuration screen, lists the
various items of data that can possibly be stored in the current project file. (Data need not have
actually been entered for every item.)

The dictionary is broken down into sections. The Project Data section lists items that
pertain to the entire project (such as the client's name). The Sample Identification section lists
the data used to identify individual samples. The dictionary also includes sections listing the
calculated data items supported for each of the test modules installed in the system.

If the current project file has been edited by the GEOSYSTEM LD4 module, the
dictionary box will include additional sections listing the information required to produce a boring
log report.

Each line in the dictionary lists one item of data that can be exported or printed. The
word in parenthesis next to each item description is the field name associated with the item; this
information is useful to individuals using the LD4 package.

To place an item of information into the page heading, drag the appropriate item from
the dictionary box to the box titled Page Heading , then drop it. Note that if there are already
items listed in the page heading box, then the place where the new item is dropped is important.
If the new item is dropped above another item in the page heading box, then the program will
insert the new item before the existing item; dropping the item below the last existing item will
place the new item last in the list. (The order in which items are listed in the page heading box
determines the order in which the items are placed on the summary page: top to bottom in the
page heading box corresponds to left to right, then top to bottom on the actual printout.)
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When an item is dropped onto the page heading box, the program will display a prompt
requesting the "field title" for the new item. This title will be printed to the left of the actual
information associated with the item: in the line shown below, the words "Project No." would be
the field title.

Project No: A95-223.01

Note that the program automatically inserts a colon (":") and a space between the field
title and the actual information.

Deleting Heading Items or Changing Heading Field Titles

To delete an item from the page heading list or to change the item's field title, double-
click on the appropriate item in the page heading list box. The program will respond by
displaying a dialog box with the item's field title which can be changed as desired. To delete the
item entirely, click the Delete button; otherwise, click OK to effect any change made to the field
title, or Cancel to discard any changes.

Table

Set up the table section by dragging data item names from the dictionary box to the box
titled Table , then dropping them. Note that if there are already items listed in the table box, then
the place where the new item is dropped is important. If the new item is dropped above another
item in the table box, then the program will insert the new item before the existing item; dropping
the item below the last existing item will place the new item last in the list. (The order in which
items are listed in the table box determines the order in which the corresponding data are placed
in export files created with the export configuration: top-to-bottom in the Table configuration box
corresponds to left-to-right in the export file. Similarly, top-to-bottom in the Table configuration
box corresponds to left-to-right table columns on printouts.)

When exporting or printing data from multiple sources, it is recommended that
one of the columns on the table be reserved for a column titled "Source" so that
samples from different sources may be distinguished from one another

When an item is dropped onto the table box, the program will display the table item
dialog box.
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The table item dialog box incorporates settings associated with individual items listed in
the Table box on the export configuration screen. This box is initially displayed when a new item
is dropped onto the Table box; once an item has been dropped, the settings may be re-
displayed and edited by double-clicking on the item.

The table item dialog box includes the following settings:

⇒ List this item always? Turning this selection off causes the program to
only export or print the selected item on rows where other data items are
also exported or printed. This is mainly useful with project files used with
LD4: for instance, when including a column for "Depth", the user may only
wish to export depths where soil samples were taken.

⇒ Column title This indicates the title of the selected column. When creating
a file of export data, the user can opt to export the column titles as the first
line of the export file. These titles can be used when importing the data into
Microsoft Access or Excel as the field names for the corresponding column
of data.

When creating hardcopy reports, the column title is placed at the head of the
corresponding column of data.

⇒ Count total number of items? As an aid in billing, the program includes an
option to include a count of the total number of items printed in a column.
This count is included as the last line of the export file or printout.

⇒ Count number of items per source? In addition to counting the total
number of items included in a particular column, the program can also be
configured to count the number of items in a column for each source that is
printed or exported.

Deleting or Changing Table Items

To delete an item from the table list or to change any of the settings associated with that
item (such as the column title), double-click on the appropriate item in the table list box. The
program will respond by displaying the table item settings dialog box, which can be changed as
desired. To delete the item entirely, click the Delete button; otherwise, click OK to effect any
change made, or Cancel to discard any changes.
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Figure Numbers

The Figure No. prompt allows the user to specify a starting figure number which
increments once for every page of the data summary printed: If a figure number is entered, it is
placed at the bottom of each printout. Figure numbers may be a combination of alphabetic and
numeric characters:

APPENDIX-1
1
1x3-10

are all valid numbers. The program will take the last number in the string (1 for the first and
second examples, and 10 for the third), and increment that, producing

APPENDIX-2
2
1x3-11

for the second page figure number.

Alphabetic figure number sequences are also supported. For example:
A-1a, A-1b, A-1c..
A1, B1, C1, D1...

To use an alphabetic or figure number, enter the beginning number at the Figure No.
prompt; before the alphabetic character that is to be incremented every page, place a caret (^).
The first example above would be entered as A-1^a; the second example would be ^A1. Note
that if the starting page/figure number is "a" or "A", you are limited to a total of 26 figure/page
numbers: in the first example, after page "A-1z", the program will omit the page number on
subsequent pages.

Margins

When printed, the report includes built-in top, bottom, left and right margins. Additional
space may be specified by selecting the Layout menu option, then selecting Margins. These
margins are specified in either centimeters or decimal inches, depending upon a setting in the
“International” group of the Windows Control Panel.

Fonts

Changes to the margins affect every configuration file
created.
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Separate typefaces and point sizes may be chosen for the data summary title, the page
heading field titles, data in the page heading, table column titles, and the data printed in the
table. To change a typeface or point size, select the Layout menu option, then select Fonts.

Next, in the Report sections box, highlight the section of the report to be changed.
When the appropriate report section has been highlighted, the Available fonts and Size boxes
will show the font and point size (in 1/72") currently selected for that section. Change either
selection as desired, then select OK to save the changes, or Cancel to discard them.

Note that the tool only supports a small number of typefaces. The
GEOSYSTEM LD4 program supports printing full-blown summary reports with a
much wider range of fonts, and provides the user with the ability to select
different type styles on a column-by-column basis.

Saving the configuration

To save a summary configuration, select Save This Configuration or Save This
Configuration As from the File menu. If Save This Configuration As is selected, a dialog box will
appear which asks for the name to save the configuration as, to be typed into the file name box.
The Directories and Projects box lists the current path. Configuration files are saved with the
extension .lfg. Note that configuration file names must be eight characters or less in
length and may not include spaces.

Selecting Sources

Normally, when a list is printed, or an export file created, the program collects data from
every source included in the currently open project. However, the program also includes an
option that allows the user to only print/export data from selected sources. To utilize this option,
check the Manually Select Sources option.

Filtering

You can further narrow what data are included on the final list by entering an equation
into the Filter Criteria box. The tool evaluates the equation for each sample card’s worth of
information: if the result is 0 or false then the data from that card won’t be listed/exported.
As a simple example, if you wish to only list the data taken between 10 and 15 feet below
ground, you would want to specify a filter such as:

(DEPTH>=10) and (DEPTH<=15)

Font changes affect every list configuration file created.
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Printing the List

Once a configuration file has been created, it can be applied to the currently open
project to produce a printed list. After creating a new summary configuration (or using the File,
Recall Existing Configuration menu option to read in a configuration file had previously been
saved to the disk), select File, Print To Printer to begin printing data.

The program will respond by displaying the standard Windows printer setup box. After
selecting the appropriate printer, select OK to continue. Next, if the Manually Select Sources
option was selected, the program will display the source selection dialog box, discussed in the
next section, otherwise, printing will begin immediately.

Source Selection Dialog Box

Figure 4.1.2 -- Source Selection Dialog Box

The source selection dialog box appears after Print has been selected from the file
menu if the Manually Select Sources box was checked in the Data Summary window. The
source selection dialog box lists the sources associated with the current project; sources with a
checkmark will be summarized. Toggle whether a particular source will be included in the
summary/export file by clicking on the source.

All the sources associated with the current project may be selected for summarizing by
clicking the Select All button. (This has the same effect as if the Manually Select Sources
option was not chosen). Clear off all of the checkmarks by selecting the Unselect All button.
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4.2 Creating a Data Export File

A file of exported data consists of lines of data: within each line are data for a single
sample. What data are included, and the order in which the data are listed, is determined by the
export configuration file.

Since the program is designed for creating hardcopy lists in addition to export files,
many of the prompts shown on the screen are not used for creating an export configuration.
When creating an export configuration file, ignore the Title , Figure No. and Page Heading
prompts, as well as the Margins and Fonts menu selections; the Table box, which determines
what is included on each row of the export file, is the only section of the window used. Setup the
Table box in the manner discussed in the section on creating printed lists.

Once an export configuration file has been created, it can be applied to the currently
open project to produce an export data file. After creating a new export configuration (or using
the File, Recall Existing Configuration menu option to read in a configuration file had previously
been saved to the disk), select the File, Export To Disk menu option to begin exporting data.

The program will respond by requesting the name of the file in which the exported data
will be placed. Note that if a file extension isn't entered, the program will use a default extension
of ".TXT", which is somewhat standard for comma-delimited ASCII files. Note that the file
name chosen must be eight characters or less in length and may not include spaces.

After entering a filename, the program will next display the export options dialog box.
When the appropriate options have been selected, select the OK button to continue. Next, if the
Manually Select Sources option was selected, the program will display the source selection
dialogue box; otherwise, the program will proceed to display the Export Option dialog, discussed
below.

4.2.1 Export Options Dialog

Figure 4.2.1 -- Export Options Dialog
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The following options are available from the export options dialog”

⇒ Separator Character Normally, data items within an export file are
separated by commas. For instance, the following is a line taken from an
export file of Grain-Size sieve percentages:

100.0,95.2,80.4,60,9,23.1

However, when including text such as project names or material
descriptions, the exported text may itself include a comma. Exporting this
data causes the resulting data file to be confusing; for example, the following
two lines were extracted from an export file of material descriptions and
Atterberg limits:

Silty Sand, 32, 20
Clayey, Silty Sand, 46, 15

The extra comma in the second line would confuse a program attempting to
import the GDM export file. To avoid this situation, the user can elect to
change the separator character to a TAB: this character is universally
recognized by programs designed for importing ASCII data.

⇒ First row has column titles Many database programs that feature
importing of ASCII text data (for example, Microsoft Access), can be
configured so that they accept the first line of the imported text file to be the
field names for the columns of imported data. Similarly, spreadsheet
programs such as Microsoft Excel can be set up to use the first line of an
imported text file as the column headings for the data being imported.

If this option is desired, make sure to type in something in response to the
Column title prompt in the table item dialog box for each table item entered.
Note that if the data to be exported will be used with a database program,
than the column title should always be a single word (e.g. "Number" instead
of "Sample Number") because database field names are always a single
word.

4.3 Configuration Files Included with the Package

Many of the laboratory test modules include a set of configuration files suitable for listing
or exporting the data from that test module. Refer to the test module’s manual for names and
examples of the module’s configuration files.
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5.Software License

There are only five paragraphs in our standard license agreement: The text of the
agreement, along with additional comments, is listed below.

⇒ The Licensee agrees not to sell or otherwise distribute the program or the
program documentation. The program is licensed only for use at the
address on this license.

We don’t prohibit transfers of a program’s license to another site or to
another company as long as we receive written notification of the transfer
and all copies of the program and its documentation are removed from
the original site .

Unlike most software vendors, our software may be used on as many
computers as necessary, as long as they are all at a single site. Use on a
computer at a temporary field office is also permitted, and, if you want, you
may install the software on a home computer as long as you will be using the
program for processing data for the company that originally purchased the
software. We don’t require any copyprotection or hardware locks.

Dial-up access or installation on a wide-area network is not permitted .

⇒ The Licensee agrees to not hold Von Gunten Engineering Software, Inc.
(VES, Inc.) liable for any harm, damages claims, losses or expenses arising
out of any act or occurrence related in any way to the use of the program.

Check your results! Computers are only tools -- data entry mistakes,
misunderstood prompts and erroneous program settings can break any
software package.

⇒ The program is warranted to fully perform the tasks described in the
program documentation. All results of the operation of the program are
subject to the further engineering judgment, prudence, and study of the
user.

If, while the program is still being sold by us, you report a reproducible
problem with the software and if we cannot provide a suitable workaround,
we will correct the problem and send you a program update.
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⇒ If the program does not perform as described, VES, Inc. will replace the
program or refund the fee paid in the licensing agreement, at its option. In
no event will VES, Inc. be liable for any amount greater than the total of the
license fee or costs paid by the licensee.

“As described” means the description and documentation given in each
program’s manuals.

Because we do not copyprotect the software, we cannot accept returns in
any circumstance other than the one documented in this paragraph of the
license agreement.

⇒ One year of free consultation and updates is included with the program. In
subsequent years, updates will be available, for a fee, at the user's option.

Please note that “consultation” does not include teaching you how to
operate the software over the telephone .

Over 80% of our support calls involve questions or problems with software
other than our own -- most of these are questions on installing and running
the software on a network. Although we can always help if you have a
question on one of our programs, we can’t provide any support for your
network. If you are having problems accessing data files on a network drive
or difficulties in sending your reports to a network printer, please consult a
network technician.

After the one year period, update costs are calculated based upon the time
that has elapsed since the last update or since the time of purchase. Check
our web site (www.geosystemsoftware.com) for information on any new
features that have been added to the software since you purchased your
copy; contact us directly if you’d like a quote for the cost to update your old
software.



=

(no source)= See no source folder=

.$P$= OQ=

.GEO= OQI=OR=

` symbol= NT=

~ symbol= NT=

¶ symbol= NS=

AASHTO= OM=

abort= NR=

Atterberg limits= PI=NMI=OM=

California bearing ratio= OM=

CBR= OM=

centimeters= See measurement units=

Column title prompt= PN=

configuring= See setup=

CONS= NMI=OM=

Copy Card menu= NR=

copyprotection= PU=

Count number of items per source prompt= PN=

Count total number of items? prompt= PN=

Cut Card menu= NRI=OO=

data=

exporting in files= PS=

Data Export Options dialog= PR=

data summary=

creating= PQ=

Data Summary and Export menu= OT=

database= OTI=PS=

decimal places= NM=

depth= NOI=PP=

description= OI=OM=

Description prompt= NO=

dial readings= See measurement units=

Dimension Units menu= NI=NO=

dimensions= See measurement units=

disk storage requirements= Q=

display resolution= Q=

Duplicate menu= NRI=NV=

Edit menu= NR=

Exit menu= NR=

feet= See measurement units=

Figure No. prompt= PO=

figure number= V=

on data summaries= PO=

Filter Criteria box= PP=

Find Text menu= NR=

Find/Replace Again menu= NR=

First row has column titles prompt= PS=

fonts= PO=

GDM= See GEOSYSTEM Data Manager=

GDM.EXE= U=

GEOSYSTEM Data Manager=

compatibility with version 1.x= NM=

defined= P=

upgrading from 1.x= S=

grain size distribution= PI=OM=

GRN-SIZE= NMI=OM=

hardware requirements= PÓQ=

inches= See measurement units=

Include "Location" prompt on all source tables promptNM=

Insert Card menu= NR=

installing= T=

keys= NS=

laboratory testing module= NMI=NVI=OS=

and figure numbers= V=

configuration= NS=

printing reports from= NR=

starting= OI=OMÓON=

laboratory testing modules= OR=

LD4= SI=OV=

compatibility with= OS=

license= PTÓPU=

LIMITS= OM=

List this item always? prompt= PN=

LL=See Atterberg limits=

Location prompt= NM=

Manually Select Sources option= PQ=

margins= PO=

material description= See description=

measurement units= NI=NOÓNPI=OM=

meters= See measurement units=
millimeters= See measurement units=

moisture density= OM=

multi-line fields= See paragraph=
network=

drive mapping= R=

installing on= R=

wide-area= RI=PT=

no source folder= OI=NV=

On reports, "Figure No." is titled prompt= V=

Options menu= See setup=

Page Heading box= OV=

paragraph= NSÓNT=

Paste Card menu= NRI=OO=

percentage= NM=

PI=See Atterberg limits=
PL=See Atterberg limits=

plate= V=

Print Menu= NR=

printer=

setup= NR=

Printer Setup menu= NR=

PROCTOR= NMI=OM=

project data=
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=QN

defined= NN=

project file=

archiving= OP=

creating= NNÓNO=

defined= NN=

moving and deleting= OR=

naming= NI=NO=

opening= NP=

Project menu= NQ=

Replace Text menu= NR=

Report Atterberg limits to prompt= NM=

report date= V=

resistance r-value= OM=

R-VALUE= OM=

sample card= O=

defined= OM=

sample cards=

cut/copy/paste= OO=

moving between= NS=

moving to a different source folder= OO=

sorting= NR=

sample length= NOI=OM=

sample number= OI=OM=

Separator Character prompt= PS=

setup= NI=NM=

Setup General Options menu= See setup=

shortcut= U=

SI=NO=
sieve= See measurement units=

Sort by Depth menu= NR=

Sort On menu= NQ=

source=

defined= NN=

Source data entry field= O=

source folder= N=

creating= NV=

defined= NV=

deleting= OO=

opening= OO=

Source menu= NR=

Source Selection dialog= PQ=

spreadsheet= OTI=PS=

starting GEOSYSTEM for Windows= U=

stratigraphy patterns= OS=

subscripting characters= NT=

summary= See data summary=

superscripting characters= NT=

swell/consolidation= OM=

Table box= PM=

testing data=

deleting= ON=

entering= OMÓON=

moving between source folders= OO=

text marking= NS=

Title prompt= OV=

Tools Menu= NS=

underlining= NRI=NS=

units= See measurement units=

US= NO=

USCS= PI=OM=

volume= See measurement units=
wide-area network= See network: wide-area=
Windows=

memory requirements= Q=

NT4 and 2000= R=

supported versions= P=

word processor= OT=


