Terms of License Agreement

1. The Licensee agrees not to sell, give away, or otherwise distribute the program or the program documentation. Each copy of the program is licensed only for use at a single address.

2. The Licensee agrees not to hold Von Gunten Engineering Software, Inc. (VES, Inc.) liable for any harm, damages claims, losses or expenses arising out of any act or occurrence related in any way to the use of the program.

3. The program is warranted to fully perform the tasks described in the program documentation. All results of the operation of the program are subject to the further engineering judgment, prudence, and study of the user.

4. If the program does not perform as described, VES, Inc. will replace the program with one that does at no charge during the first year after licensing. In no event will VES, Inc. be liable for any monetary compensation to the licensee. Software usage is implicit agreement to these terms.

5. One year of free consultation and updates is included with the program. In subsequent years, updates will be available, for a fee, at the user’s option.
# QUALITY CONTROL - CONCRETE Ver. 2

## TABLE OF CONTENTS

### SECTION 1 QUICK START GUIDE

<table>
<thead>
<tr>
<th>1.1</th>
<th>INSTALLATION ..................................................</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1.1</td>
<td>Network Server with Users at Workstations ..........</td>
<td>1</td>
</tr>
<tr>
<td>1.1.2</td>
<td>Peer to peer Network with Users at Workstations</td>
<td>1</td>
</tr>
<tr>
<td>1.1.3</td>
<td>Standalone Workstation ..................................</td>
<td>1</td>
</tr>
<tr>
<td>1.1.4</td>
<td>Installation Steps .........................................</td>
<td>1</td>
</tr>
<tr>
<td>1.2</td>
<td>RUNNING QC-CONCRETE AND FIRST TIME SETUP .........</td>
<td>2</td>
</tr>
<tr>
<td>1.3</td>
<td>TO ACCESS GEOSYSTEM DATA MANAGER PROJECTS .......</td>
<td>3</td>
</tr>
<tr>
<td>1.4</td>
<td>TO ADD NEW REPORTS .......................................</td>
<td>3</td>
</tr>
<tr>
<td>1.5</td>
<td>TO ADD NEW BREAKS ..........................................</td>
<td>3</td>
</tr>
<tr>
<td>1.6</td>
<td>TO PRINT OR PREVIEW TEST REPORTS ...................</td>
<td>3</td>
</tr>
<tr>
<td>1.7</td>
<td>TO PRINT A BREAK LIST .....................................</td>
<td>3</td>
</tr>
</tbody>
</table>

### SECTION 2 INTRODUCTION

<table>
<thead>
<tr>
<th>2.1</th>
<th>PROGRAM FEATURES ...........................................</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1.1</td>
<td>Reporting Capabilities ..................................</td>
<td>5</td>
</tr>
<tr>
<td>2.1.2</td>
<td>Test Types Handled .......................................</td>
<td>6</td>
</tr>
<tr>
<td>2.1.3</td>
<td>Data Management Features ...............................</td>
<td>6</td>
</tr>
<tr>
<td>2.1.4</td>
<td>User Interface Features ..................................</td>
<td>7</td>
</tr>
<tr>
<td>2.1.5</td>
<td>Other New Ver. 2 Features .............................</td>
<td>7</td>
</tr>
<tr>
<td>2.2</td>
<td>FUTURE ADDITIONS ..........................................</td>
<td>7</td>
</tr>
</tbody>
</table>

### SECTION 3 USER PREFERENCES

<table>
<thead>
<tr>
<th>3.1</th>
<th>NO INDUSTRY STANDARD FOR STRENGTH TEST REPORTS</th>
<th>9</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.2</td>
<td>OPTIONS ON THE GENERAL TAB ................................</td>
<td>9</td>
</tr>
<tr>
<td>3.2.1</td>
<td>A Note About Terminology ..................................</td>
<td>10</td>
</tr>
<tr>
<td>3.2.2</td>
<td>Automatically Incrementing Test and Specimen Numbers</td>
<td>10</td>
</tr>
<tr>
<td>3.2.3</td>
<td>Suggest most likely value for first specimen number on a new report</td>
<td>10</td>
</tr>
<tr>
<td>3.2.4</td>
<td>Sorting the Test Numbers ..................................</td>
<td>11</td>
</tr>
<tr>
<td>3.2.5</td>
<td>New Test Status .............................................</td>
<td>11</td>
</tr>
<tr>
<td>3.2.6</td>
<td>Average Test Strength ......................................</td>
<td>12</td>
</tr>
<tr>
<td>3.2.7</td>
<td>Warn or prevent if specimen number is not unique in the entire database</td>
<td>12</td>
</tr>
<tr>
<td>3.2.8</td>
<td>Warn or prevent if specimen number is not unique in the report</td>
<td>12</td>
</tr>
<tr>
<td>3.2.9</td>
<td>Reporting Compliance with Strength Specifications</td>
<td>12</td>
</tr>
<tr>
<td>3.2.10</td>
<td>Warn If Report Has No Specimens ........................</td>
<td>13</td>
</tr>
<tr>
<td>3.2.11</td>
<td>Tips, Warnings and Confirmation Prompts (Local) ...</td>
<td>13</td>
</tr>
<tr>
<td>3.2.12</td>
<td>Enabling the “Program in Use” message (Local) ....</td>
<td>13</td>
</tr>
<tr>
<td>3.2.13</td>
<td>Default Fracture Type ......................................</td>
<td>13</td>
</tr>
<tr>
<td>3.3</td>
<td>OPTIONS ON THE REPORT SETUP TAB .....................</td>
<td>13</td>
</tr>
<tr>
<td>3.3.1</td>
<td>Selecting a Template to be Used with a Test Type ....</td>
<td>15</td>
</tr>
<tr>
<td>3.3.2</td>
<td>Setup for PDF File Creation ................................</td>
<td>15</td>
</tr>
<tr>
<td>3.3.3</td>
<td>PDF Storage Folder for Project and Default Folder Setup</td>
<td>16</td>
</tr>
<tr>
<td>3.3.4</td>
<td>Changing the Data Entry Prompts (Active Fields) ....</td>
<td>17</td>
</tr>
<tr>
<td>3.3.5</td>
<td>Changing the Checkbox Arrangement ....................</td>
<td>18</td>
</tr>
<tr>
<td>3.3.6</td>
<td>Changing the Break Table Arrangement ..................</td>
<td>19</td>
</tr>
<tr>
<td>3.3.6.1</td>
<td>General Break Table Options ............................</td>
<td>19</td>
</tr>
<tr>
<td>3.3.6.2</td>
<td>Properties for Break Table Field ........................</td>
<td>20</td>
</tr>
</tbody>
</table>
Section 1
Quick Start Guide

1.1 Installation

Note: If you are updating to Version 2 from Version 1 follow the directions in Appendix C

Before installing consider how many users the program will have, who the main user will be, and how your computer system is maintained. Install it according to one of the following sets of directions, depending on which one fits your situation the best:

1.1.1 Network Server with Users at Workstations

One of the most common computer configurations is to have a server with users at individual workstations. In this case it is recommended that the software be installed only on the server. Users may then start the program from any workstation that has permission to access QC-Concrete. Some of the program's preference settings will apply only to that workstation; some will be universal to all users. Follow the installation instructions in Section 1.1.4 and install on your server for this type of configuration.

1.1.2 Peer to peer Network with Users at Workstations

Another common computer configuration is to have a group of computers interconnected with no designated server, and with users at individual workstations. In this case it is recommended that the software be installed only on the computer where it will primarily be used, as it will run the fastest on the computer it is installed on. Users may then start the program from any workstation that has permission to access QC-Concrete. Some of the program's preference settings will apply only to that workstation; some will be universal to all users. Follow the installation instructions in Section 1.1.4 and install on the primary user's computer.

1.1.3 Standalone Workstation

QC-Concrete is most easily used on a standalone computer. In this case simply follow the installation instructions in Section 1.1.4 and install on the selected computer.

1.1.4 Installation Steps

1. Insert the CD in the appropriate computer. If the setup program does not autostart, navigate to and run SETUP on the CD. The simplest way to do this is starting at the Windows Desktop, select Start, Run. Enter D:SETUP, select OK. D: is typical, if your CD-ROM drive is a different letter, use it.

2. Read the setup dialogs and do what they say. When you get to the Choose Destination Location dialog, it will suggest C:\Program Files\GEOSYS. If that is not your GEOSYSTEM for Windows folder, choose Browse, and navigate to the correct folder. If you do not have GEOSYSTEM for Windows installed, any new folder you choose will work.
3. When you get to the Select Program Manager Group dialog it will suggest GEOSYSTEM. This is where your QC-Concrete shortcut will be in your Start Menu. Select another program group if you would prefer.

4. While it is installing, please take a moment to complete the License Agreement and return it or a copy of it to us.

5. When you get to the Installation Complete dialog, click Finish and you are done installing. Unless you are running Windows XP you should re-boot when suggested by the installer.

### 1.2 Running QC-CONCRETE and First Time Setup

If, during installation, you chose to have a shortcut placed on your desktop, double-click on it to start the program. Using the start menu, choose Start, Programs, GEOSYSTEM, QC-Concrete (or other Program Group that you may have chosen) to run the program. When the opening screen appears you can begin to get acquainted with the software.

The first time you run the program, choose Help>Contents and peruse the topics, just to let you know what help is available. These quick start directions are very brief, you will find the program's help system valuable in answering questions. If you don't find what you want under a help topic, check the table of contents and index of the manual to locate additional details.

It is useful to get set some preferences set, so select Tools>Options, then:

1. Both of the "Automatically increment" options should be unchecked, just to simplify things at the start.

2. If your company identifies tests with numbers only, select the option to sort numerically. If they are alphanumeric, turning this off will cause the sort to be alphabetical.

3. Choose the Report Setup tab and you'll see the 13 test types handled by QC-Concrete. If you have custom report formats, they should already be selected. If they are not, select them to replace the corresponding BASIC report formats. They are all numbered to make it easy. Refer to Section 3.3.1 for additional information about selecting report formats.

4. Choose the Break List Setup tab and you'll see the name of the Break List format. If you have a custom report format, you should select it.

5. Read the 3 break list options on that tab, choose the test selection option that best fits. Choose Help for additional information.

6. Set up the report data and specifications data for each form you will be using, for more information see Section 6.1.7.
1.3 To Access GEOSYSTEM Data Manager Projects

All projects in GDM are accessible. Choose Edit>New Project and click on Browse to identify the Path to Existing GDM projects. References to “GDM” are synonymous with “LD4” - the GEOSYSTEM Drilling Log Program which also hosts the lab modules.

Note: The GEOSYSTEM for Windows Data Manager (GDM) or the GEOSYSTEM for Windows Drilling Log program (LD4) does NOT need to be running for QC-Concrete to run. Also note that, for simplicity, all references to the GEOSYSTEM Data Manager in this manual will be simply GDM, regardless of whether GDM or LD4 are being used.

1.4 To Add New Reports

Select Edit>New Report and type in a new test number. If using dates, enter a sample date as well. More information is in Section 4.3.2.

1.5 To Add New Breaks

Click on the first blank specimen number cell on the break data table. Type in a new specimen number and press enter. Follow with the rest of the appropriate information.

1.6 To Print or Preview Test Reports

Test Reports are the main type of report for submittal to clients. Click on Reports>Report Selection to display the form that allows selection of which Test Reports to print. At the top of the form are the current selection method and the number of reports that meet the requirements of that selection method. Close that form and select Reports>Print Test Report and the reports selected will print. To preview and print only the current report click on the preview button, or select Reports>Preview Current Report. Report formats and PDF file storage locations are selected under Tools>Options>Report Setup.

1.7 To Print a Break List

A Break List is a list of all specimens scheduled to be broken on a specific day. Click on the Break List button, or select Reports>Break List to print it. Select the date for the break list, if different than the current date. Report formats are selected under Tools>Options>Break Lists Setup.

Note: The GEOSYSTEM for Windows Data Manager (GDM) or the GEOSYSTEM for Windows Drilling Log program (LD4) does NOT need to be running for QC-Concrete to run. Also note that, for simplicity, all references to the GEOSYSTEM Data Manager in this manual will be simply GDM, regardless of whether GDM or LD4 are being used.
Section 2
Introduction

The GEOSYSTEM for Windows Quality Control for Concrete program (QC-Concrete) is for the management of cement product testing data. It accepts, stores, and reports results of tests on cement products such as concrete, mortar and grout. A wide variety of specimen types are handled by the software, including cylinders, cubes, beams, and sawed specimens. Version 2 is an overhaul of the original version, with many enhancements. The sections which follow describe the many features of the software.

2.1 Program Features

QC-Concrete was designed to be an efficient, time saving tool for the materials testing industry. Here are some of its noteworthy features.

2.1.1 Reporting Capabilities

Original program features:

- Print all reports for a day, week, or month with a single click.
- Print lists of all specimens needing to be broken.
- Print summaries of all breaks for a project.
- Print envelopes or labels for all copies on a distribution list.
- Individual report templates for each different test type handled by the program.
- Preview reports before printing.
- Custom report formats can be ordered from GEOSYSTEM Software.

New, Ver. 2 features

- **PDF file reports**: Now QC-Concrete can create PDF format files without the addition of Adobe Acrobat. - Described in Section 3.3.2
- **Multiple page test reports**: If you have more than the allowable number of specimens in a test (10 for cylinders, 6 for beams and cubes and 4 for masonry) the program will now print on as many report pages as needed to include all of the reports. -Described in Sections 6.1.3 and 6.1.5.
- **Pick a standard note for each specimen**: Report notes about each specimen may be selected from a user-defined list of notes. These notes then can be printed on custom reports (not standard reports though). - Described in Section 4.5.12.
- **Print reports about mixes in the mix database**: You can now have a printed copy of the data entered for a particular mix. -Described in Section 5.2.
- **Print reports about all mixes in a project**: You can now have a printed copy of the data entered for all mixes in a particular project. -Described in Section 5.2.
- **Print reports listing all projects**: You can now have a printed copy listing the projects in your database. - Described in Section 6.5.
- **Print reports listing all clients**: You can now have a printed copy listing the unique clients in your database. -Described in Section 6.5.
- **Printing option for all new reports**: You may now choose to print all new reports which have not yet been printed. -Described in Section 6.1.1.
- **Custom reports may include color**: Color logos and color text can now be incorporated into custom report templates.
2.1.2 Test Types Handled

- Concrete cylinders, ASTM C 31 and C 39, AASHTO T 23 and T 22
- Concrete beam flexural strength in third point loading, ASTM C 78 and AASHTO T 97
- Concrete beam flexural strength in center point loading, ASTM C 293 and AASHTO T 177
- 2x2 Mortar cubes ASTM C 109 and AASHTO T 106
- Grout specimens ASTM C 1019
- Cored concrete cylinders ASTM C 42 and C 39 and AASHTO T 24 and T 22
- Sawed concrete beam flexural strength in third point loading, ASTM C 42 and C 78 and AASHTO T 24 and T 97
- Sawed concrete beam flexural strength in center point loading, ASTM C 42 and C 293 and AASHTO T 24 and T 177
- Grout cubes ASTM C 942 and C 109 (no AASHTO)
- Mortar cylinders ASTM C 780 and C 39 (no AASHTO)
- Grout cylinders ASTM C 39 (no AASHTO)
- Masonry block prism ASTM C 1314 (no AASHTO)
- Masonry block ASTM C 140 (no AASHTO)
- Soil cement cylinders ASTM D 4832 (no AASHTO)

2.1.3 Data Management Features

**Original program features:**

- Tests can be referenced by project number, report number and date, or just project number and report number.
- Access your data locally, on another PC on the network, or on a network server.
- Program can be run by more than one user at a time, additional users are notified that they are not alone when they start it up.
- 4 relational databases used for data management efficiency.
- Set projects to inactive status, or archive them entirely when done.

**New, Ver. 2 features**

- **Import client data for new projects:** New projects can now automatically retrieve the client data from the QC-Concrete database or, by using an optional module, external databases. -Described in Section 4.3.2.
- **Break tables have new fields:** To increase the flexibility of QC-Concrete for custom reports the break table has new fields available for Actual Age, Actual Break Date, Curing Location, Days of Field Cure and Days of Lab Cure. A user option is available when Actual Break Date is used to highlight specimens in yellow if the actual break date is different than the scheduled break date. Enable the yellow highlight using the break table setup form -Described in Section 3.3.6.
- **Update inactive status:** This new utility will scan reports and specimens to ensure all records are correctly designated active or inactive based on the status of their project. -Described in Section 7.1.
- **Can determine pass/fail based on ages other than 28 day:** Reports with a 7, 56 or other age at which the strength is required to meet specifications can now have their average strengths calculated. -Described in Section 4.4.3.
- **Find out you've entered a project number wrong and have already entered several reports? - No problem now:** New "Change Project Number" feature -Described in Section 9.8.
2.1.4 User Interface Features

Original program features:

- Arrange data entry fields to suit individual preferences.
- Use built in calculations for specimen results, or calculate yourself.
- Set font, color, and date formats to suit.
- Find any specimen without entering its project or report numbers.
- Enter results in the order they are listed on a daily break sheet.
- Logical data (Yes or No) can be entered in checkboxes.
- Toolbar buttons for frequently performed tasks.
- Generous set of configuration options for a wide variety of reporting customs.

New, Ver. 2 features

- **Failing tests shown in red**: Option now available to display failing breaks in red. -Described in Section 3.3.6.1.
- **Break table colors**: The break table can now be set up to display alternating rows in different colors. -Described in Section 3.6.1.
- **Duplicate dimensions from previous specimen in break table**: The break table can now be set up to duplicate the dimensions entered for the previous specimen. -Described in Section 3.3.6.1.
- **Order of break table columns**: The columns in the break table can now be rearranged. One handy use for this is to make them appear in the same order as they do on the final report. -Described in Section 3.3.6.2.
- **Individual user preferences**: Individual users on a network installation can pick colors, fonts, and several other preferences without affecting all users. -Described in Section 3.1.
- **New toolbar button for New Projects**: Clicking on the New Project lets you bypass the file menu navigation.
- **Link to website**: Clicking on the GEOSYSTEM logo takes you directly to our website.
- **Pick mixes from mix database**: When entering data, at the Mix Number field, double-click on the data entry field for Mix Number, or click on the mix tool button and select a mix. That mix is automatically entered in the Mix Number field.
- **Scroll through data from previous tests while entering field data**: The data you just entered for a different report is now at your fingertips when entering new reports. Press Ctrl-[ and Ctrl-] when entering any field data to see previous values entered. -Described in Section 4.4.3.

2.1.5 Other New Ver. 2 Features

- **Version 2 is faster**: QC-Concrete is now a "32 bit" program. That means that it makes more efficient use of your computer's memory and calculating power. The previous version of the program was a "16 bit" program.
- **No more drive letter mapping**: Network paths like "\\Server\Concrete" are now supported. -Described in Section 9.7.
- **Database operations are more efficient**: A newer version of the underlying database "engine" is used, called Jet 3.0. In addition to being newer, it is 32 bit instead of 16 bit (see the first item for a discussion of these terms).
- **Import break data from break machine data file**: QC-Concrete can now automatically merge break data from a digital load display data acquisition file. This feature is only available with an optional module. Contact GEOSYSTEM for more information.

2.2 Future Additions

Several additional features will become a part of the program in the near future:

- Invoice list export
Introduction

- Statistical analysis companion software
- Client report repository

Let us know about any other additional features which would be beneficial.
Section 3
User Preferences

This chapter discusses configuring QC-Concrete’s options.

3.1 No Industry Standard for Strength Test Reports

A lot of options have been built into QC-Concrete to satisfy the multitude of reporting requirements and traditions associated with cement products testing. It also accommodates some preferences which individual users may have. These settings are identified on the various options tabs by the term “Local”. These settings are effective only on the workstation they are set at. This section is intended to assist you in setting up the program to most nearly fit your reporting needs, and personal interface preferences. To set program preferences you select Tools > Options

3.2 Options on the General Tab

The options form has 5 tabs, each with options for a particular aspect of the program. Its general appearance is as shown below:

![Options Screen, General Tab](image)

Figure 1 - Options Screen, General Tab

Descriptions of these options are given in the paragraphs which follow.
3.2.1  A Note About Terminology

In the industry there are many different terms used for compressive strength tests. The Project is usually identified by a **Project Number**. This is also commonly called a **Job Number** or **Contract Number**. Likewise, tests on a project may be referred to by **Test Number**, **Report Number**, **Set Number**, **Lab Number**, **Cylinder Set Number**, and etc. For purposes of this manual, a specific project on which testing is being conducted will be identified by a **Project Number**, and the set of cast or cut specimens will be called a test and referred to by a **Report Number**, and optionally, its **Date of Placement**.

3.2.2  Automatically Incrementing Test and Specimen Numbers

When a new test or specimen is added the user must enter its number. As a shortcut, the program can look up the last test for the project or the last specimen for the test and simply add 1 to its number, creating the new number. Additionally, for new tests, the program can suggest a first specimen number, (if specimens are uniquely numbered throughout a project). To activate any of these timesavers, select *Tools* > *Options*, and on the **General Tab** click on or off the appropriate option, as shown below:

| Automatically increment test numbers: | ✔ |
| Automatically increment specimen numbers: | |
| Suggest most likely value for first specimen number on a new report: | By project: | By counter: |

![Figure 2 - Auto Increment and First Specimen Number Options](image)

3.2.3  Suggest most likely value for first specimen number on a new report

You can have QC-Concrete suggest the most likely value for first specimen number on a new report. It can do it in one of 2 ways; by looking through the current project for the highest alpha-numerical specimen number, or by referencing an alpha-numerical counter. The choice is made by selecting either "By project" or "By counter" on the Options > General tab as shown in the illustration below:

| Automatically increment test numbers: | ✔ |
| Automatically increment specimen numbers: | |
| Suggest most likely value for first specimen number on a new report: | By project: | By counter: |

![Figure 3 - Suggest the most likely value for first specimen number on a new report](image)

Since the by counter option generates new specimen numbers based on a counter you must be able to adjust the counter position. See Section 9.3 for information about adjusting the counter. It also has the advantage of suggesting the next specimen number anytime a specimen is added, not just on new reports. I.e. if you have an existing report with specimens 45, 46, and 47, and 2 more unassigned specimens are brought in from a field cure location, and the counter is at 76, the 2 new specimens will be added to the report as 77 and 78, preserving the uniqueness of specimens throughout the database.
3.2.4 Sorting the Test Numbers

The report number selection box is used for choosing the number of the test to be retrieved. It is in the center in the illustration below:

![Figure 4 - Project Number and Test Number Selection Lists](image)

If appropriate for your system of numbering tests, i.e. they are primarily numeric and not alphanumeric, the list of tests in this selection box and be sorted. To activate numeric sorting select Tools > Options, and on the General tab click on or off the appropriate option, as shown below:

![Figure 5 - Option to Sort the Test Number List Numerically](image)

If this is not checked test numbers will be sorted alphabetically (10 is before 2 when sorted alphabetically).

3.2.5 New Test Status

One very useful printing option is the ability to print all new reports. Some users may wish to have their tests (reports) be given new test status anytime a load is entered or changed. To have the program do this, select the appropriate option as shown below:

![Figure 6 - Option to Give Edited Reports New Report Status](image)

On the top of the report data entry screen is some information about the report. If it is black and includes the word "Printed" then the report's status is printed. The following illustration shows a report with printed status:

![Figure 7 - Title on Report with Printed Status](image)

Similarly, if it is unprinted, the title says "Unprinted", and is colored blue.
3.2.6 Average Test Strength

The program can automatically find the average test strength for you. To enable this option, select Tools > Options and on the General tab, click where it says calculate the average test strength. When this is activated, the average strength for each of the specimens having a strength at the design age. It is inserted in the field "Average28" whenever the strengths for the design age specimens are recalculated.

3.2.7 Warn or prevent if specimen number is not unique in the entire database

With some specimen numbering conventions each specimen has a unique ID number. To alert the user when a previously used specimen number is entered, check this option. The duplicate specimen warning occurs in a message box, but does not prevent the user from entering the duplicate. To prevent the entry of duplicate specimen numbers, check the box labeled "Prevent".

| Calculate the average test strength |  |
| If specimen number is not unique in the entire database: Warn: ☑ Prevent: ☑ |
| If specimen number is not unique in the report: Warn: ☑ Prevent: ☑ |

Figure 8 - Duplicate Specimen Options (in entire database)

Note: Requiring unique specimen numbers in the database is not compatible with the option to suggest the next specimen number based on a project. It can only be used by counter or with no specimen number generation at all. See section 3.2.3 for more information.

3.2.8 Warn or prevent if specimen number is not unique in the report

With some specimen numbering conventions all specimen in a given set of specimens (aka report) have the same ID number. To allow this "Warn" and "Prevent" must NOT be selected. For other numbering schemes, and if you will ever need to archive, retrieve, or merge a branch database, these must be selected.

| If specimen number is not unique in the entire database: Warn: ☑ Prevent: ☑ |
| If specimen number is not unique in the report: Warn: ☑ Prevent: ☑ |

Figure 9 - Duplicate Specimen Options (in report)

3.2.9 Reporting Compliance with Strength Specifications

Some custom report formats will report whether or not the average test strength meets the specified strength. Users with this sort of custom report should have this option enabled. Check to insure that is by selecting Tools > Options and on the General tab, check where it says Use checkboxes 0, 1, 2 and 3 for reporting required strength compliance. Users with this feature on their custom reports may also see checkboxes on their data entry screens labeled something similar to:
The program will automatically fill in checkboxes 1, 2, and 3 however the user may override the values determined by the program by checking checkbox 3.

### 3.2.10 Warn If Report Has No Specimens

Some users may wish to be alerted if they have a report with no specimens. Check this option to have an alert occur when quitting, changing reports, changing projects, adding a new report, or adding a new project.

### 3.2.11 Tips, Warnings and Confirmation Prompts (Local)

There are some new user features in the program, intended to assist in learning the operation of the program. These are:

- A tip form is displayed when arranging data entry fields.
- Display a message before allowing changes in the number of columns the data entry screen has.
- Display a confirmation prompt before deleting a specimen from the break table.
- Date fields are checked for valid dates
- Selecting layout styles waits for confirmation
- Attempting to enter more data than allowed causes a message to be displayed
- Entering more breaks than the value entered for "Number of Specimens"
- Entering a break on a day other than the scheduled break date pops up a message

To disable these features select Tools>Options and on the General tab, click where it says Check this box to turn off new user features. This setting of this preference only affects the workstation it is set on.

### 3.2.12 Enabling the “Program in Use” message (Local)

In a multi-user environment it may be helpful to know if other users have the database open. A message can appear at startup to notify the user of that case. To enable the message, select Tools>Options and on the General tab, click where it says Enable “Program in Use” warning at startup. Note that when enabled, the message may also be triggered by running the program after a program crash. This setting of this preference only affects the workstation it is set on.

### 3.2.13 Default Fracture Type

During break data entry for cylinders the fracture type is entered. Since the most common type of fracture is conical, you may wish to have "A" inserted automatically. Likewise any other value could automatically be inserted by entering it here. Leave it blank to disable use of default values for fracture type. This is the same default value used during by the Break List Data Entry form. If it is changed there, it is also changed here.

### 3.3 Options on the Report Setup Tab

Strength tests on beams, mortar cubes, cylinders, etc. each have their own particular reporting requirements. So each of the 13 different test types supported by QC-Concrete has a specific report format associated with it. There
User Preferences

are also variations among testing labs in how a report for each test type should look. As a result, there are a number of considerations which go into test report setup. There are several miscellaneous settings which affect all test types, not just selected test types. Settings which are not specific to a particular test type are in the Data Entry Screen Layout section (see Section 3.7).

The basic report templates have basic names, being BASIC0.CRP - BASIC12.CRP. They correspond to the test types as follows:

<table>
<thead>
<tr>
<th>TEST TYPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Cast cylinder - ASTM C39</td>
</tr>
<tr>
<td>1</td>
<td>Beam, third point loading - ASTM C 78</td>
</tr>
<tr>
<td>2</td>
<td>Beam center point loading - ASTM C 293</td>
</tr>
<tr>
<td>3</td>
<td>Mortar cube</td>
</tr>
<tr>
<td>4</td>
<td>Grout specimen ASTM C 1019</td>
</tr>
<tr>
<td>5</td>
<td>Cored cylinder</td>
</tr>
<tr>
<td>6</td>
<td>Sawed beam - ASTM C 78</td>
</tr>
<tr>
<td>7</td>
<td>Sawed beam - ASTM C 293</td>
</tr>
<tr>
<td>8</td>
<td>Grout cube ASTM C 942</td>
</tr>
<tr>
<td>9</td>
<td>Mortar cylinder ASTM C 780</td>
</tr>
<tr>
<td>10</td>
<td>Grout cylinder ASTM C 39</td>
</tr>
<tr>
<td>11</td>
<td>Masonry block prism ASTM C 1314</td>
</tr>
<tr>
<td>12</td>
<td>Masonry block ASTM C 140</td>
</tr>
<tr>
<td>13</td>
<td>Soil cement cylinder ASTM D 4832</td>
</tr>
</tbody>
</table>

| TEST TYPE | DESCRIPTION |

Table 1 - Test Type Descriptions

Some users have commissioned a set of custom templates to be created by GEOSYSTEM Software. In these cases, the template names are the abbreviated company name plus a number representing the test type.

Example: ACME4.CRP would be the 3x3 mortar cube format for ACME Engineering.

In addition to the BASIC report templates, there is a set of templates which include extra space at the top of the form so it can be printed on company letterhead. These are the LH-UL report templates. The “LH” stands for Letter Head, and the UL stands for Units Labels. These particular forms also add units to each test result for which they are appropriate. There is also a set of templates which converts data entered in US units to Metric units on the reports. These are the USMET templates.
3.3.1 Selecting a Template to be Used with a Test Type

Why would you need to change the template being used? You won’t, unless you receive some custom forms. If you do, copy them to the program folder, if you don’t know where it is, click on Help> About QC-Concrete. The path to the program folder is listed there. After copying, do the following:

1. Select Tools> Options, and click on the Report Setup tab. The form will look like the following example:

![Report Setup Tab in Program Options](image)

2. Click on one of the test types in the listbox on the left.

3. Click on the dropdown arrow on the combo box and pick the custom template for that test type from the templates listed.

4. Repeat for all the test types that have custom templates.

Since the length of specimen numbers varies from company to company there is an option to change the justification of the specimen numbers on reports. This is the only user configurable report option. If your specimen numbers are too far to the right on reports, selecting centered or left justification can make them look better.

3.3.2 Setup for PDF File Creation

Each QC-Concrete project can be designated to print to the printer or print to a PDF disc file. Reports printed to PDF files can be e-mailed as e-mail attachments, and viewed by the recipient by using the Adobe Acrobat Reader.

To set up a project to print its reports to PDF files go to Tools/Options/Report Setup and in the PDF Setup frame click on the Setup Now button. Scroll through the projects and click on the project desired. The currently
selected PDF folder for that project, if any, is shown. If the folder cannot be found a message "THIS PATH DOES NOT EXIST" is displayed. Invalid paths are treated as though they were blank and reports are sent to the printer. Unless set up this way to produce PDF files, all new projects will be sent to the printer. An explanation of these setup options follows:

- To select/create a PDF storage folder click on the **Browse for new path** button.
- To set the PDF storage folder to the default location click on **Set to default path**.
- To set the default path, in the **Default Path** frame click on **Browse for new path**. This is also set/changed when you pick a folder on the print preview form.

**NOTE:** PDF files created by QC-Concrete are editable by the recipient. To make them read only using the RC4 security method from RSA Corp. you will need to use Adobe Acrobat, not included with QC-Concrete.

PDF file names are created using the Project Number, Report Number, and current date or placement date (see below for how to set which date). As an example the PDF file name "2003-FC-0005_1_10-01-03.PDF" is from project 2003-FC-0005, report number 1, printed on 10/1/03. Summary Reports, Project Reports, Mix Reports, and Break Lists also may be created as PDF files if desired. To do so, click on the PDF button on the preview. The file will be saved as ProjectReport_Date_Time.PDF, and etc. For the reports the folder designated as the default storage location is always used.

### 3.3.3 PDF Storage Folder for Project and Default Folder Setup

To select the PDF folder and default PDF folder go to **Tools/Options/Report Setup** and in the **PDF Setup** frame click on the **Setup Now** button. Under **Path to [project] PDF Storage Folder** the current location where the project's PDF files are stored is shown. Under **Default Path** the default path is shown. To change either of these locations, click on the appropriate **Browse for new path** button. At the following screen you can do the following to choose these new folder locations:

- Select the drive to use. Network drives must be mapped to a drive letter to show up.
  - or
- Select the folder to use.
- Create a new folder in the selected folder.

**NOTE:** If you selected a mapped drive, be sure to have that drive mapped and available the next time QC-Concrete is run. Otherwise you will need to quit, establish the connection, then restart. There is nothing elegant about the way QC-Concrete handles files. Use a mapped network drive only if you are comfortable and experienced with drive mapping.

There are 2 other PDF file user options, what date to use in the PDF file name, and whether or not to prompt for making chosen PDF folder during a print preview the permanent PDF folder for a project.

- **Date to Use When Building PDF Names** - you can choose to use either the Current Date or the Date Placed in the PDF file name. Filenames are of the form S91003-2400_1_02-28-03.PDF where S91003-2400 is the project number 1 is the report number and 02-28-03 is the date (either current or date placed).

- **Set PDF Storage Folder at Preview?** When a PDF file is created for a project that does not have a PDF Storage Folder set for it yet you must use a save dialog to pick a destination location for the PDF. If you would like, the program can offer to make the chosen folder the PDF folder. If you will never use that option, you can choose to disable it.


3.3.4 Changing the Data Entry Prompts (Active Fields)

The main set of data entry prompts is configurable. Rarely will you need to make any changes here, but since each of the program’s test types needs a particular set of data entry prompts, and since these prompts may be different for users of customized report forms, they may be changed. The form used to change data entry prompts is shown in the following figure:

![Figure 11 - Setting Active Fields](image)

If the need arises, select Tools > Options, and click on the Report Setup tab. Click on one of the test types in the listbox on the left. Click on the Data Entry Settings combo box, and select Field Data Prompts (Active Fields). Click on the command button labeled Edit Selected Item. Editing is done as follows:

- **To make an inactive field active:** Click on the inactive field then click on the blue, right pointing arrow.

- **To make an active field inactive:** Click on the active field then click on the blue, left pointing arrow.

- **To change the title of a field:** Both active and inactive fields can have their titles changed. To do so, click on the active (inactive) field then click on the title textbox and make the changes.

- **To change the allowed data entry length of a field:** To change the allowed length, click on the desired active field then enter a maximum length in the Length of Field text box. It can be any number up the maximum length.

- **Set Default Fields:** Each test type has a factory default set of active and inactive fields. If things are really out of whack, choose Set Default Fields to use the best arrangement of active fields for that test type.

**Other information the form:** Other information on the form includes:

- **Database Field Name:** The internal name used to refer to the database field
- **Type of Field:** The type of data handled by each database field
- **Report Name:** The name of the report currently used by the Test Type
Test Type - The Test Type for which the active fields are being edited

3.3.5 Changing the Checkbox Arrangement

None of the standard reports include checkboxes, however, many custom reports do. Rarely will the user need to make changes here. These instructions are included for the possibility that, for certain custom forms, the user may need to make minor changes to the checkbox arrangement. The form for working with checkboxes has the following appearance:

![Figure 12 - Configuring Checkboxes](image)

Checkboxes have only 2 values, checked and unchecked. Additionally, there may be groups where if one is checked, the others should not be. Such mutual exclusivity is of value on reports where there are fields such as “Field cure box heated? □ Yes □ No”. There are 10 checkboxes available for data entry and a maximum of 5 checkbox groups. Rarely will you need to make any changes here, but if instructed to do so you may need these directions.

To change the checkbox settings, select Tools > Options, and click on the Report Setup tab. Click on one of the Test Types in the list on the left. Click on the Data Entry Settings combo box, and select Checkbox Grouping. Click on the command button labeled Edit Selected Item. Editing is done as follows:

- **Creating a Checkbox Group:**
  In the one of the checkbox columns, click on all the checkboxes to be added to the group. To remove a checkbox from a group, click on it again. Note that a checkbox cannot be added to more than one group.

- **Selecting a Default Checkbox:**
  In the one of the checkbox columns, RIGHT click on the checkbox that should initially be checked for a new test. It will be designated as the default by a blue circle around it.

- **Selecting OK or Cancel Changes:**
  Selecting OK will save the changes, selecting Cancel will return the checkbox groupings to the way they were before opening this form.
3.3.6 Changing the Break Table Arrangement

The appearance and function of the break table, where the break test results are entered, also depends on the test type. Rarely will you need to make any changes here, but since the layout and prompts may be different for users of customized report forms, they may be changed. The form for these changes has the following appearance:

![Figure 13 - Configuring the Break Table](image)

### 3.3.6.1 General Break Table Options

These are settings for the entire table:

- **Number of lines for the break table title:** Set for 1 to 4 depending on the complexity of the column titles. If set for less than 4, some lines of the title in the properties frame are disabled.

- **Disable all automatic calculations:** Check this box to prevent the program from calculating break dates, stress, area, etc. from the measured data entered for a given specimen.

- **Turn row red if below specified strength and yellow if actual date is not the scheduled date:** Check this box to have breaks falling below the specified strength be shown in red and breaks broken on a day other than the day scheduled in yellow.

- **Duplicate dimensions from the previous specimen:** Check this box to have the dimensions (diameter, area, sides, etc.) be duplicated from the previous specimen.
• **List of standard break notes:** Certain custom report forms are set up to use one of the break table fields for an extensive note such as:

"B) The 7 day result projects that the specified strength will likely be met at 28 days according to a typical strength:age relationship. (7 days)"

To save the time of typing such a note repeatedly they can be entered here, for use with the custom form. Add new notes by entering them in the dropdown box and then clicking on the Add button. To delete an entry, select it from the list and press F6 (function key F6). To restore an accidentally deleted note, click in the box and press Ctrl-V (to paste the deleted entry back in).

• **Number of characters displayed:** To limit the number of characters displayed for a standard break note. Some notes can be very long and displaying the entire note can be difficult to view.

• **Click RESET to restore the default calculations for ...:** There are standard properties/calculations for each Test Type. Clicking on the RESET text replaces the current properties with the default properties.

  **Note:** Refer to Section 3.6.1 for instructions about how to set the sort order for the specimen table.

### 3.3.6.2 Properties for Break Table Field...

Chances are there will never be a need for a user to re-configure the Break Data Table titles, column widths, numeric formats, or calculations. In certain cases, users with custom reports may need to do so. If the need arises, select Tools>Options, and click on the Report Setup tab. Click on one of the Test Types in the listbox on the left. Click on the Data Entry Settings combo box, and select Break Table Layout. Click on the command button labeled Edit Selected Item and you are ready to configure the break table for that test type.

Select the column you need to change by clicking on the database field name in the list on the left. The database field names are fairly meaningful except Dim1, Dim2 and Dim3. Dim1 is the diameter for cylinders and Dim1 and Dim2 are sides of cubes. For beams, Dim1 is the width, Dim2 is the depth, Dim3 is the span and area is the distance to the support when the fracture is out of the middle third of the beam. See the illustration below for help with these dimensions.

![Figure 14 - Beam Dimensions](image.png)

**Note:** The names of the fields in the break table may or may not indicate their use, e.g. the field Area may be used for "distance outside of center third" in the case of beams.

After selecting a field, make changes to the properties for that field as follows:

• **Visible:** All break data fields needed for the report or calculations should be visible.

• **Insert default fracture type:** Check this box for the column that should receive the default fracture type. The value of the default fracture type is set elsewhere - see paragraph 3.2.13 for additional information.
• **Dropdown list:** One of the break table columns can have a dropdown list. Check this box for the column that should display it. Setting and changing the contents of the dropdown list are described above.

• **Minimum column width:** When automatic column widths are enabled, setting this to some amount prevents the column from being set narrower than that amount. When automatic column widths are not enabled, this is unavailable.

• **Calculation result:** If the field contains the result of a calculation, it is selected using this list box.

• **Calculation component:** If the field contains a component used in a calculation, it is selected using this list box.

• **Numeric format:** Pick from the list of numeric formats to use when the data entered for the column is displayed, or, more importantly, when calculated results are displayed.

• **Equation for calculation:** If the field contains the result of a calculation, the equation used is shown here. Cannot be edited, for reference only.

• **Title lines (1-4):** The column titles displayed during input. If less than 4 title lines are enabled, it is because of the setting for Number of lines for the break table title, also on this form.

• **Position:** The order of the fields may be changed. Select the field to be moved and click on the up/down arrows to move.

---

**Note about calculating the area for masonry block prisms:** The factory default settings for Masonry Block Prisms do not include a calculation for the area (per C 1314). If desired, add this calculation in by selecting Area and changing its calculation component from Masonry Prism Net Area to None. Then change the calculation result from None to Area. Check that Dim1 is set at the Width for Masonry Prism, and Dim3 is set as the Length for Masonry Prism. Since this includes the area of the hollow it is only valid if the unit is grouted.

---

### 3.3.7 Logo Sizing Checkbox

Also on the Report Setup tab is a checkbox called:

![Uncheck for logo resizing compatible with older custom templates](image)

This is in the program so that older custom forms with logos can be used with versions of QC-Concrete newer than 1.6.0. It is not ordinarily needed.

### 3.3.8 Report Printing Sequence

Report Printing Sequence  Select how to order reports when a batch of reports is printed.

• **According to project number, then report number**
• **According to first specimen number on report, alphabetic**: The first specimen number, using alphabetic interpretation, on each report will govern the order of printing.

• **According to first specimen number on report, numeric**: The first specimen number, interpreted as a number, on each report will govern the order of printing.

• **According to report number**

• **According to project number, specimen number**: Using this sort, the first specimen number is used and interpreted alphabetically.

### 3.3.9 Distribution List Options

The user may choose to have multiple copies of a report printed, one for each entry in the distribution list. To select this option, To get to this option select *Tools* > *Options* and click on the *Test Reports* tab, then check the checkbox labeled: *Print a report for each name on the distribution list*.

Additionally, the program can be set to insert the name and address from the distribution list into the report being printed for it. To get to this option select *Tools* > *Options* and click on the *Test Reports* tab, then check the checkbox labeled: *Put distribution list addresses on reports*. When this option is selected the program knows where to print the distribution list information by referencing a field map that associates a distribution list field with a field on the report. This map is defined using *Tools* > *Options*, the *Test Reports* tab, and then the *Setup Distribution List Map* button. The form looks like the example shown in Figure 15:

![Distribution List Field Map](image)

**Figure 15 - Distribution List Field Map**

The titles in the left hand column are the fields printed on most reports. The selectable fields on the right are the distribution list fields which the program will then substitute for the report fields when the distribution list copies are printed. Ordinarily this will be set at the factory and not need changing.
3.4 Settings for Break Lists

Break Lists are reports listing specimens to be broken on a specific day. Break List reports have some setup options that should be set to your preferences. Select Tools>Options, and click on the Break Lists Setup tab. The tab will have the following appearance:

![Options Screen, Break List Setup Tab](image-url)

Select the appropriate settings as follows:

3.4.1 Name of Template to be Used for Break Lists

Select from the dropdown combobox the name of the report format to be used. The description of each format is included with the name. Examples of some of these reports are shown in Section 6.2.2.

3.4.2 Specimens to be Included

- **All unbroken specimens up to and including the break date**: Select this option for a complete break list of all specimens which may need testing. This is recommended because using this option you will always know if a specimen was missed.

- **Unbroken and prematurely broken specimens for the exact break date**: Select this option for a break list of all specimens which need testing and all specimens inadvertently tested early.

- **Only unbroken specimens for the exact break date**: This is not a very comprehensive option but if you have a lot of specimens in the database that were scheduled but skipped intentionally, it will weed them out.

3.4.3 Specimen Sort Order for the Report

- **None**: Select this option for no break list specimen sorting. They will print in the sequence that they
exist in the database.

- **Alphabetic sort:** Alphabetic sorts are good for specimen IDs which use letters or numbers and letters in combination. It will, however, put “15A” before “2A”, because that is the correct alpha sort order.

- **Numeric sort:** Numeric specimen sorting will ignore all letters. It will place “2A” before “15A”, but will not necessarily recognize or sort specimens like “15A, 15B, 15C” possibly giving the “C” specimen before the others, etc.

- **Project, Report, Specimen (numeric):** Lists specimens by Project Number, Report Number, then Specimen Number (numerically).

- **Project, Date, Report Number sort:** Lists specimens by Project Number, Placement Date, Report Number.

- **Project, Date, Report No. (numeric Reports only), Specimen (numeric Specimens only):** Lists specimens by Project Number, Placement Date, numerically the Report Number and numerically the Specimen Number.

### 3.4.4 Omit Reserves

Check this box to omit reserve specimens on the break list. Reserve specimens are those designated to be held for future testing only if needed. They are identified by their age entry, which can be a specific number, such as “100” or some text, such as “Reserve” or “HOLD”.

### 3.5 Settings for Screen Colors, Date Formats, and Fonts

QC-Concrete allows choosing certain screen colors, formats for dates, and data entry fonts. Instructions for each of these are in the following sections.

#### 3.5.1 Setting Colors (Local)

Select *Tools* > *Options*, and click on the *Colors, Dates and Fonts* tab to access color options. The colors chosen are a local user option, affecting only the machine on which the colors are selected. Options available are:

- **Click on Color Panel to Select**
  In the *Set Colors* panel, find the background that you want to set the color for and click on the color panel next to it. The color panel is the colored rectangle as shown in the illustration below:
3.5.2 Setting Date Formats (Global)

Select Tools>Options, and click on the Colors, Dates and Fonts tab to access date options. These settings affect all users of the program.

- **Date Formats**: there are several preset date formats to choose from. Contact VES, Inc. if you need a format that is not shown. Any of these formats may be used if you are working strictly with dates from Jan. 1, 2000 forward. If dates prior to Jan. 1, 2000 are also going to be used you **MUST** use one of the two four digit year formats. Additionally, you **MUST** set the short date format for windows to one which uses a 4 digit year. For help making this change to Windows refer to Windows Help under the topic of “Regional Settings, Date Formats” (or something similar).

- **Date Today**
  The current date is used on some reports. This sets the format used to print the current date.

- **Date Placed**
  This is the date format for the Placement Date.

- **Date Sampled/Submitted**
  This is the date format for Sampled and Submitted.

- **Date Broken**
  This is the date format for the Break Table.

- **Convert MMDDYY input to a date checkbox**
Check this box if you want to enter MMDDYY (ex. 020501) as a date and have it converted to the MM/DD/YY (ex 2/5/01) date format.

### 3.5.3 Setting Data Entry Fonts (Local)

Select *Tools > Options*, and click on the *Colors, Dates and Fonts* tab to access font options. When choosing fonts, the list is a subset of all the fonts available on your system. Set the subset up using the *Font Subset* button. Fonts chosen are a local user option, affecting only the machine on which the fonts are selected.

- **Titles**
  This is the font for Field Data Titles.

- **Data Fields**
  This is the font for user entered Field Data.

- **Break Table Heading**
  This is the font used for the headings on the Break table.

- **Break Table Data**
  This is the font used for the data entered in the Break Table.

- **Set Font Subset**
  If you want to, you may use this option to limit the fonts available to only those of interest when picking data entry font preferences. Click on *Set Font Subset* then double click on available fonts to add them, double click on subset fonts to remove them from the subset.

### 3.6 Screen Layout Settings

Miscellaneous data entry screen settings are discussed in this section. These settings affect all Test Types, not just specific Test Types. Settings which are Test Type specific are in the *Report Setup* section. Select *Tools > Options*, and click on the *Screen Layout* tab to access these options.

#### 3.6.1 Data Entry Screen Settings

- **Disable automatic sizing of break table columns:** QC-Concrete will adjust the widths of the break table columns automatically. It may be preferable to set them to fixed widths that don’t change. To do so check this box.

- **Disable data entry for calculated fields:** To have the cursor automatically skip over fields in the Break Data Table which have automatically calculated results check this option.

- **During data entry copy dates to blank date fields:** On the data entry screen there are typically 3 dates to be entered, the Date Submitted, Date Sampled and sometimes the Date Placed. To expedite data entry, these three can be set to automatically be filled in. Check this box to do so.
• **Recalculate break table strengths upon display:** The program recalculates a break strength anytime data used to calculate the strength changes. But, if the rounding method for strength is changed, such as nearest 5 to nearest 10, having this option selected will update all strengths for a report as soon as the report is displayed.

• **Sort break table by specimen number:** The break table displays the specimens in the same order that they were entered in. To change it to show them in alphabetic order, click this option.

  **Note:** that Data Entry Screen settings below the dark line are local, meaning they only affect the machine they were set on.

• **Percent of screen for start of second column (Local):** When the screen layout is set for 2 columns the second column can start at a position determined by the user. There is a minimum position of 4000 twips, which is 55% at VGA resolution, 33% at SVGA resolution, and 26% at XGA resolution.

• **Use 2 colors for rows of the break table:** To make it easier to keep track of which specimen is which you can have alternating rows be different colors. The color used is the system color assigned to 3-D control button faces, so you don’t have a whole lot of choice.

3.6.2 **Selection Titles**

Terminology applied to the selection fields varies among laboratories. The title to be displayed for the Project selection, Report selection, Test Type, and Date selection list boxes can be set by the user here.

The width (% of normal) of each title can also be set. You can adjust the width of the 3 report selection combo boxes and the Test Type selection box. Set the values for “% of normal” to 100% to use the factory default widths. Set the widths to greater or less than 100% for sizes that fit your terminology better. The setting for widths is a local setting, it does not affect all users of QC-Concrete.

3.7 **Changing the Data Entry Screen Layout**

You may wish to re-arrange the positions of the data entry prompts. This section describes how to arrange 1 or 2 columns of prompts, and how to drag and drop the data entry prompts and fields in the Project and Field Data portion of the screen.

3.7.1 **Arranging into 1 Column**

Select **Tools>Layout>Field Data - One Column**. Data input prompts will appear in a single column down the screen.

3.7.2 **Arranging into 2 Columns**

Select **Tools>Layout>Field Data - Two Columns**. Where there is enough room, data input prompts will appear side by side. The second column will start at the position selected in **Tools>Options>Screen Layout**.

3.7.3 **Arranging To Use All Available Space**

Select **Tools>Layout>Field Data - No Columns**. Data prompts can be positioned using all available space.
3.7.4 Arranging the Screen

Whether you are using the One Column, Two Columns, or No Columns, the order of the prompts can be changed. Select Tools>Layout>Arrange Field Data Section or right click on any prompt and select from the local menu. Data entry will be prohibited, and data entry prompts will turn red when pointed to, meaning it can be dragged to a new location. Drag any data entry prompt over any other data entry prompt and drop it. The new location for the dragged and dropped prompt will be the next one following the one it was dropped on. To move a prompt to the first position, drag it to the first prompt and drop it, it will become the second prompt. Then drag and drop the first prompt onto the second prompt to swap their positions. You can also change the title at the top of the section, just right click on it and enter the new title. Select Tools>Layout>Arrange Field Data Section again to turn off the arranging mode.

3.7.5 Screen Arrangement Tips

- **Drag and drop**: To drag and drop, point to a prompt. When it turns red, hold the left mouse button down and move to a new location on the screen. A little gray box attached to the mouse pointer indicates the prompt is being carried. Drop it on top of another prompt, and it will assume a position immediately following it. If the destination is more than a few fields away, you may need to drag it, drop it, scroll the screen, and drag and drop again.

- **Selecting which fields are active**: Refer to Section 3.3.2 Selecting Active Fields.

- **Shortcut to the Layout menu**: Point to any Field Data prompt and right-click the mouse.

- **Grouping Checkboxes**: Checkboxes can be grouped so that only one box in the group can be checked at a time. Information which is best conveyed as Yes or No can be entered and displayed as Checkboxes. Examples of this type of information are “Were the specimens field or lab cured?” and “Was a hi/lo thermometer used in the cure box?” Refer to section 3.3.5, Changing the Checkbox Arrangement for additional information.

3.7.6 Title for the Screen

At the top of the Field Data screen there is a title describing the input screen for that type of test. To change it, select Tools>Layout>Arrange Field Data Section or right click on any prompt and select it from the local menu. Right click on the title and enter the new one in the input box.
Section 4
Data Entry

When using QC-Concrete you will spend most of your time starting projects, adding tests to these projects, adding break results to these tests. All of these tasks are described in this chapter.

4.1 The Data Entry Screen

When QC-Concrete starts, the opening screen displays three sections. It will appear similar to the following example:

Figure 18 - Main Data Entry Screen

The top section is the Test Selection section which has the data that uniquely identifies the test, and the type of test. The middle section is the Field Data section which has information about the project, placement location and conditions, mix, and tests performed in the field. The bottom section, the Break Data section, has information about the individual specimens broken and the strength results. Some easy changes may be made to how this screen displays this data.
When entering Field Data, it may be preferred to simply view the Field Data and not any of the Break Data. Click on the little compression testing machine to turn off the Break Data table display. Click on it again to show the Break Data again. Another way to do the same thing is to select Tools > View > Break Data to show or hide the Break Data section.

Likewise, when entering Break Data, it may be preferred to simply view the Break Data table, and not any of the Field Data. Click on the little drum mixer truck to turn off the Field Data display. Click on it again to again show the Field data. Another way to do the same thing is to select Tools > View > Field Data to show or hide the Field Test Data section.

The portion of the screen covered by the Field Test Data and the Break Data can be adjusted. Click on the tool buttons to change the sizes.

4.2 Editing Existing Tests

To edit a test that has already been entered, select the test by picking the Project and Test Number, and optionally, the Test Date. Either enter the data in the appropriate selection box (it will seek to the closest match), or use the dropdown arrow to display all Projects, Tests, and Test Dates. The selection section will appear like one of the following:

![Figure 19 - Selecting Tests When Not Using Dates](image)

![Figure 20 - Selecting Tests When Using Dates](image)

For more information about using dates in the test selection process see Section 3.2.1.

Note: The Test Type is also selected in this top area of the main program screen, although it has nothing to do with the report selection process. It just made it easier to design the software to have it up there.

4.3 Projects - Selecting, Adding, and Entering Data

Projects can be added 2 ways:

1. Creating a new blank project.
2. Picking an existing GEOSYSTEM for Windows project.
After starting a new QC-Concrete project, add the first test to that project, and enter the Project Data. Any information which is constant over the life of the project is considered to be Project Data. Items which are Project Data are:

- Project Number
- Contract Number
- Client Name
- Company
- Address
- Project Contractor
- Field Engineer

and 10 Entries for a distribution list each including Name, Company, and 3 lines of Address

**Note:** Project data items may have different prompts than these, e.g. Name may be prompted as Attn: etc.

As you enter additional tests for that project the project data will be the same. Any changes made to the project data for any test will be carried over to all tests previously entered. This is because there is only one copy of the project data saved.

3. Importing Client Data from an external database. This feature is available only with the Client Import Add-in (additional charge). This Add-in is custom designed to import data from another ODBC database which you may have already available as part of you business record keeping process. For additional information about this option call GEOSYSTEM Software.

The following sections explain in detail selecting projects, adding projects and entering project data.

### 4.3.1 Selecting Projects

Existing projects are selected using the Project Number drop down box, as illustrated below:

![Figure 21 - Selecting Projects](image)

Click on the dropdown arrow and either select a project from the list of projects, or begin typing the project number, the program will search for it one character at a time. Whenever the Project Number is changed the lists of Test Numbers and Sample Dates (if used) are updated for the new project.
4.3.2 Adding Projects and Selecting a Project Template

To start a new project, click on the icon in the toolbar, or select Edit>New Project. Projects can be added 3 ways, as discussed at the beginning of this section. More information on each of these is given in this section. The New Project form has the following appearance:

![New Project Form](image)

**Figure 22 - Adding a New Project**

1. Creating a new blank project: Enter the new project number in the textbox at the top of the dialog. Begin using the new project by clicking OK to return to the QC-Concrete main screen and select the project from the project listbox.

2. Importing a GEOSYSTEM Data Manager project. Select from the list of existing GDM projects the project to be added to QC-Concrete. The list of projects are those found in the folder named as the Current path to GDM Projects. To change the location where GDM projects are found, click on the Browse button. Then select the drive or network location to use, and the folder to use.

In both cases you have several options which can save you time by filling in some of the Project Data:

- Using another project’s client/project data: When starting a new project you can have the program copy the data from an existing project. The fields copied are:
CLIENT (usually client's name)
CCOMP (usually the client's company name)
CADDR, CADDR2, CADDR3, CADDR4 (usually the client's address)
PROJECT, PROJECT2, PROJECT3, PROJECT4 (usually the project name)
PROJ_NUM (the project number)
CONT_NUM (usually the contract number)
CONTRACTOR (usually the project contractor's name)
FIELD ENG (usually the field engineer)

• To do so click on the Select Project button. A list of existing projects will be displayed, similar to the following example:

![Select Project Window](image)

**Figure 23 - Selecting a Project to Repeat Project Data From**

• **Always use this project**: If all of your work is done for the same client, check the box labeled "Always copy client information from this project".

• **Copy distribution list too**: Additionally, if the distribution list for the new project is the same or similar to the reference project, time can be saved by copying it as well. Check the box by "Copy distribution list too" to do so. The distribution list includes the data fields:
  
  - CC1 (usually the client's company name)
  - CCA11, CCA21, CCA31, CCA41 (usually the client address)
  - PROJ_NUM (the project number)

  There are 10 sets of these 5 fields which comprise the entire distribution list. These will always be copied as well, if the "Always copy client information from this project" box is checked.

• **Using another project's Report Data and Test Standards (Creating a Project Template)**: Another time saver is to copy an existing project's miscellaneous project data, both the report data and the test standards. See Section 6.1.7 and section 6.1.8 for additional information about Report Data and Test Standards. To do so click on the Select Project button. A list of existing projects will be displayed as shown in Figure 23. To always copy that existing project's miscellaneous project data check the box for "Always copy the report data and the test standards from this project.

• **Project View / Company View**: Either all existing clients or all existing projects may be listed when choosing the source for a new project's client information or misc. report data. Choosing the "Project View" displays all projects, including multiple projects belonging to the same clients. The "Company View" displays only unique companies.

• **Importing an existing client from an external database**: The third method of adding new projects involves importing client data from an external database. Licensees of the Client Importer Add-in have QC-Concrete
set up to retrieve client information from an external database. Clicking on the Data Source button brings up the Select Import Source for Client Data form, shown in the next figure.

Instructions for using the options on this form are in the appendix supplied to customers who have licensed the Client Import Add-in.

4.3.3 Entering Project Data

Project Data and Field Test Data are entered in the same area of the main screen. The data is simply typed in the blanks beside each prompt. Because each report includes both Project Data and Field Data they are mixed together on the same screen. The major difference is that Project Data is the same for all reports on a given project, and only needs to be entered once.

**Note:** Changing the Project Data for any report changes it for all reports.
The Project Data entry screen appears as shown in Figure 25:

![Figure 25 - Entering Project Data](image)

**4.4 Tests - Selecting and Adding**

A Test is a particular sampling of a cement product and the casting of its specimens. Companies refer to a test in various ways, and even in this manual, the program itself, and the help system, various terms may be used. So, consider Report, Set and Test Report to be synonymous terms.

The test's Project Number, Report Number and, optionally, Placement Date are used to uniquely identify the test and retrieve it. The data gathered in the Test is referred to in this program as Field Data and Break Data (discussed in the next section). Tests are selected by picking the Placement Date (if dates are being used), and the Report Number. Any information which is specific to a particular test is considered to be Field Data. In the QC-Concrete program, 58 items of Field Data may be entered. For a typical cast cylinder these are:

<table>
<thead>
<tr>
<th>Date Sampled</th>
<th>Load Number</th>
<th>Admixtures</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date Placed</td>
<td>Plant Number</td>
<td>Admixtures</td>
<td>Remarks</td>
</tr>
<tr>
<td>Date Submitted</td>
<td>Time Batched</td>
<td>Slump</td>
<td>Average 28 Day Strength</td>
</tr>
<tr>
<td>Location of Sample</td>
<td>Time Sampled</td>
<td>Air Content</td>
<td>Check Box 0</td>
</tr>
<tr>
<td>More Location</td>
<td>Time in Mixer</td>
<td>Concrete Temp</td>
<td>Check Box 1</td>
</tr>
<tr>
<td>More Location</td>
<td>Mix Number</td>
<td>Ambient Temp</td>
<td>Check Box 2</td>
</tr>
<tr>
<td>Placement Description</td>
<td>Design Age</td>
<td>Field Cure High</td>
<td>Check Box 3</td>
</tr>
<tr>
<td>More Placement</td>
<td>Design Strength</td>
<td>Field Cure Low</td>
<td>Check Box 4</td>
</tr>
<tr>
<td>More Placement</td>
<td>Material</td>
<td>Unit Weight</td>
<td>Check Box 5</td>
</tr>
<tr>
<td>Placement Method</td>
<td>Time Placed</td>
<td>Yield</td>
<td>Check Box 6</td>
</tr>
<tr>
<td>Supplier</td>
<td>Sampled By</td>
<td>Curing Method</td>
<td>Check Box 7</td>
</tr>
<tr>
<td>More Supplier</td>
<td>Nominal Size</td>
<td>Field Cure Days</td>
<td>Check Box 8</td>
</tr>
<tr>
<td>Contractor</td>
<td>Number of Specimens</td>
<td>Weather</td>
<td>Check Box 9</td>
</tr>
<tr>
<td>Truck Number</td>
<td>Batch Size</td>
<td>Remarks</td>
<td>Remarks</td>
</tr>
<tr>
<td>Ticket Number</td>
<td>Water Added</td>
<td>Remarks</td>
<td>Remarks</td>
</tr>
</tbody>
</table>

**Figure 26 - Field Data Items as Defined for Cast Cylinders**

*Note:* These items can be renamed, so they may be different than those displayed when running the program.

*Note:* To display only the Field Data select *Tools* > *View* > *Break Data* or click the toolbar button. The Break Data will disappear. This makes it easier to see all the fields being used.
4.4.1 Selecting Tests

How tests are selected depends on whether dates are used in test identification (see Section 3.2.1). If dates are used, first select the date from the Placement Date list. Then select the test in the Report Number list.

1. Select the Placement Date (if used): Click on the down arrow in the Placement Date combo box and click on the Placement Date needed. Or you can type in the Placement Date there and it will seek the correct date. Whenever the Placement Date is changed the list of Test Numbers changes to list tests for the new date.

2. Select the Report Number: Click on the down arrow in the Report Number combo box and click on the Report Number needed. Or you can type in the Test Number there.

4.4.2 Adding New Tests

Click on the New Test button on the toolbar: or click on Edit>New Report.

Figure 27 – Adding New Reports

Figure 28 – Adding New Reports - With the Option to Start Test Numbering Daily
If you are using dates as part of the report selection, enter the new Date. Then enter the new Test Number. Click on OK to add the test, if the Report Number (and Date if used) match an existing test, it will not be added as a new test.

**Note:** QC-Concrete has an option to increment test numbers automatically. If you would like each new test to be numbered one (1) greater than the previous, select *Tools > Options* then click on the "Automatically increment test numbers" checkbox. Likewise, if you do not want these suggested test numbers, turn the option off.

You can save some time if the new test has similar field data to the most recent test for that project. Check the box labeled "Repeat data from this project's most recent test" All of the Field Data (except Checkboxes) is copied from the most recent test.

### 4.4.3 Entering Field Data

A test's Field Data occupies the same screen area as the test's Project Data. It is entered in the same way, by typing the data and pressing Enter or Tab to move to the next field. There are several special Field Data items, the Test Type, Placement Date, Mix Number and checkboxes.

- **Test Type:** Although the Test Type is part of the Field Data for a test, it is selected differently, using a list in the test selection area. It is handy there because, being a list, it is not easy to include it on the main data entry screen and because the Test Type controls the way the data entry screen appears. CQC-FD supports 8 types of cement products tests:
  
  1) Cast Cylinders  
  2) Third Point Beams  
  3) Center Point Beams  
  4) Mortar Cubes  
  5) Grout Prisms  
  6) Cored Cylinders  
  7) Sawed Third Point Beams  
  8) Sawed Center Point Beams  
  9) Grout Cubes  
  10) Mortar Cylinders  
  11) Grout Cylinders  
  12) Masonry Block Prism  
  13) Masonry Block

Select the Test Type right after any new test is created, so the correct data entry screen is displayed.

**Note:** The Test Type, although displayed along with the Report Selection Keys, is not a Report Selection Key. When the Test Type is selected the Field Test Data screen will use the appearance you have selected for that Test Type.

- **Date fields**

  The contents of the Placement Date field cannot be changed if the Placement Date is being used as a Report Key Field. See Section 3.2.1 for additional information.

  There are 3 date fields in the Field Test Data section. If they have information in them they should be valid dates in order for them to be used by the program. The Placement Date (sometimes called Cast Date) is very important, it is the date the specimen was cast, and the age of the specimen begins at 0 with this day. The Sample Date is also very important, and it is just that, the date the sample was taken (or cut or cored). The Date Submitted is for specimens brought to the lab by a third party.

**Note:** You can insert the current date by double-right-clicking on any date field and selecting *date*, then pick the format you want.

- **QuickData**

  You can save time by selecting repetitively entered data from a local submenu. Right click twice on a data entry field and a submenu will appear. That will bring up a list of 4 choices, Date, and 3 user
defined categories. Click on the category you want, and 10 user defined selections will appear. Select the item or items needed, each one selected will be added to the existing data. If you select (highlight) the existing data first then QuickData will replace it instead of appending to it. To set up QuickData fields go to (Reports > Misc. Project Data > Report Data for this Project). The last 3 Report Data lists are used to store the QuickData choices. For more information about setting up QuickData lists see Section 6.1.7

- **Checkbox fields**
  Information which is best conveyed as Yes or No can be entered and displayed as Checkboxes. Examples of this type of information are “Were the specimens field or lab cured?” and “Was a hi/lo thermometer used in the cure box?” Clicking on the box beside the prompt puts a checkbox in it, or removes it. Checkboxes can be defined in groups where only one can be true at a time. When a Checkbox in a group is checked, all others in that group become unchecked. For more information about setting up Checkboxes see Section 3.3.5.

- **Design Age field**
  The age entered as the design age will be the age of specimen used for the average test result calculation.

- **Pick mixes from mix database**: When entering data, at the Mix Number field, double-click on the data entry field for Mix Number, or click on the mix tool button and select a mix. That mix is automatically entered in the Mix Number field. At the same time, the Supplier, Design Strength and Primary Design Age will be imported from the Mix Table to the Field Data Table. More information about the mix database is in Section 5.

- **Scrolling through data from previous tests**: To save time, any particular Field Data field can be quickly filled with data for that field from a previous test. When the data entry cursor is on any of the Field Data fields, press Ctrl [ or Ctrl ] to scroll backwards and forwards through the data.

4.4.4 Cut, Copy and Paste Field Data

When editing Field Data, any information entered can be cut, copied and pasted between data entry fields. To do so, highlight (either with the mouse or shift/arrow keys) then use Ctrl-C to Copy, Ctrl-X to Cut, and Ctrl-V to paste.

4.5 Breaks - Selecting, Adding, and Entering Data

Results of laboratory break tests on specimens are entered in a table at the bottom of the main data entry screen. Each specimen gets a row in the table. To access Break Data for a specimen, first select the test to which the specimen belongs by setting the selection boxes to the test's Project Number, Placement Date (if used) and Test Number. If the Specimen Number has already been entered, you may go directly to it by choosing Edit > Find a Specimen or by using the shortcut keys Ctrl-F. If there is more than one specimen with that number you can find the next one by selecting Edit > Find Again or by using the shortcut key F3.

**Note:** To display only the Break Data select Tools > View > Field Data, or click on the toolbar button: . The field data will disappear.

4.5.1 Selecting Breaks

To edit the data for a particular specimen, click on the cell that contains the data. If it is a result, like Break Date or Strength, you may be prevented from changing the data. If that occurs, you must change the data from which
the result is calculated. This behavior is optional and is changed by selecting *Tools > Options*, clicking on the *Screen Layout Tab*, and selecting or deselecting the option to *Disable data entry in calculated fields*.

### 4.5.2 Adding Breaks

To add a specimen, click on or move to the blank row below the specimens already entered (marked with the star in the row selector box). Then enter the new specimen’s data.

![Figure 29 - Break Data Table](image)

**Note:** QC-Concrete has an option to increment specimen numbers automatically. If you would like each new specimen to be numbered one (1) greater than the previous, select *Tools > Options* then click on the "Automatically increment specimen numbers" checkbox. Likewise, if you do not want these suggested specimen numbers, turn the option off.

To make it easier to follow a particular row of data you can set an option to use a different color for alternating rows. See Section 3.6.1 for additional information.

### 4.5.3 Entering Break Data

Some general considerations about entering break data are:

- To edit the data for a particular specimen, click on the cell that contains the data. Click again to set the edit point, or press F2 to enter edit mode. As data is entered for a specimen pre-defined calculations can occur. These include break date, area, strength, modulus of rupture and percent of required strength.
- Whether or not the cursor skips over calculation results is also a user option, as discussed in Section 3.6.1.
- Any number of specimens can be entered, however the report format being used to print them will probably be limited to 6, 8 or 10 specimens. If more specimens are entered than there is room for on the report, additional reports will print.
- The layout and calculations of the Break Data Table depends on the test type and, if needed, can be configured by the user. Section 3.3.6 has additional information about configuring the Break Table.
- For C 78 Beams (third point), if the fracture occurs outside of the center third, enter the average distance from the nearest support to fracture in the column *Distance to Support (Outside of Center)*.
- If there is more data in a field than can be displayed due to the column being too narrow, point the mouse cursor at the cell and wait, it will be completely displayed in a pop up.

### 4.5.4 Warning Colors

A specimen row may be displayed in red or yellow to indicate a warning. Red indicates the specimen strength is below the required strength. Yellow indicates the actual break date does not match the scheduled break date (used primarily with custom forms). Warning colors are optional, select whether or not warning colors will be displayed as described in Section 3.3.6.1.
4.5.5 Deleting Specimens

To delete a specimen, left click on the row selector to select the row. Selected rows are displayed in a different color. Then press the Delete key on the keyboard. Only one row at a time can be deleted.

4.5.6 Resizing Rows and Columns

Resize the row height by pointing to the row divider line between row selector buttons (see illustration below). When the cursor becomes the resize cursor, click and move the mouse up and down to resize. Resize the column width by pointing to the row divider line between row selector buttons (see illustration below).

![Figure 30 - Terminology for the Break Table](image)

When the cursor becomes the resize cursor, drag the column dividers left and right to resize.

**Note:** You cannot resize columns unless the automatic column width features of the software are disabled. To disable them, select **Tools > Options** and click on the Screen Layout tab. Check the appropriate box to disable the automatic width features. Also, if the rows are not high enough, the cursor may not display properly. If the cursor vanishes, resize the rows larger.

4.5.7 Cut, Copy and Paste in the Break Table

Any information entered in the Break Table can be cut, copied and pasted between specimens. To do so, highlight (either with the mouse or shift/arrow keys) then use Ctrl-C to Copy, Ctrl-X to Cut, and Ctrl-V to Paste.

4.5.8 Moving Around the Break Table and Other Editing Keys

The following table lists the keys to use to move around the Break Table:


<table>
<thead>
<tr>
<th>Key:</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Beginning of row</td>
</tr>
<tr>
<td>End</td>
<td>End of row</td>
</tr>
<tr>
<td>Insert</td>
<td>Has no effect</td>
</tr>
<tr>
<td>F2</td>
<td>Enter edit field mode</td>
</tr>
<tr>
<td>Esc</td>
<td>Revert to previous cell contents</td>
</tr>
<tr>
<td>Right Click</td>
<td>Average strength of selected rows</td>
</tr>
</tbody>
</table>

Table 2 - Keys Used to Move Around the Break Table

4.5.9 Break Table Calculations

Break date, area and strength are some examples of data that are calculated by the program. The formulas used are shown on the break table configuration form. See section 3.3.6 for additional information. Cored cylinders and masonry block prisms both require the application of corrections factors to the calculated strength. These correction factors are related to the length/diameter or height/width ratio and are determined using the following tables:

<table>
<thead>
<tr>
<th>Cored Cylinders ASTM C 42:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Length/Diameter Ratio:</td>
<td>Correction Factor Applied to Strength:</td>
</tr>
<tr>
<td>&gt; 2</td>
<td>not acceptable</td>
</tr>
<tr>
<td>2.00</td>
<td>1.00</td>
</tr>
<tr>
<td>1.75</td>
<td>0.98</td>
</tr>
<tr>
<td>1.5</td>
<td>0.96</td>
</tr>
<tr>
<td>1.25</td>
<td>0.93</td>
</tr>
<tr>
<td>1</td>
<td>0.87</td>
</tr>
<tr>
<td>&lt; 1</td>
<td>not acceptable</td>
</tr>
</tbody>
</table>

Table 3 - Cored Cylinder Correction Factor

<table>
<thead>
<tr>
<th>Masonry Block Prisms ASTM C 1314:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Height/Least Lateral Ratio:</td>
<td>Correction Factor Applied to Strength:</td>
</tr>
<tr>
<td>&gt; 5.0</td>
<td>not acceptable</td>
</tr>
<tr>
<td>5.0</td>
<td>1.22</td>
</tr>
<tr>
<td>4.0</td>
<td>1.15</td>
</tr>
<tr>
<td>3.0</td>
<td>1.07</td>
</tr>
<tr>
<td>2.5</td>
<td>1.04</td>
</tr>
<tr>
<td>2.0</td>
<td>1.0</td>
</tr>
<tr>
<td>1.5</td>
<td>0.86</td>
</tr>
<tr>
<td>1.3</td>
<td>0.75</td>
</tr>
<tr>
<td>&lt; 1.3</td>
<td>not acceptable</td>
</tr>
</tbody>
</table>

Table 4 - Masonry Block Prism Correction Factor

For values between those specified the correction factor is found by linear interpolation.

Also calculated is the Percent of Design (or Percent of Required). In order to have these calculated you must have entered a Design Strength and Design Age. If those are present, all specimens with the same age as the Design Age have a Percent of Design calculated using the specimen’s strength (as rounded and displayed) divided by the design strength. Other age specimens may have their Percent of Design calculated as well. Simply enter their required strengths into the break table. To save time, enter the Mix ID used be in the Mix Table, and enter an age and design.
strength for the age of the specimen. All other specimens with the same Mix ID will also have this new design age and strength applied to them. See Figure 33 for an example of the Mix Table with 3 sets of design age and design strength.

### 4.5.10 Averaging Strengths

Select the rows with the strengths to be averaged by clicking on the row selector while holding down the control key. Right click while pointing to the break table. You will get a message giving you the average. Click OK and the average will be inserted in the Average28 field. The automatic determination of the average strength is preferable to using this manual method.

### 4.5.11 Default Fracture Type and Fracture Type Menu

- **Using a Default Fracture Type**
  The program can supply a default value for cylinder fracture types. It will automatically be entered as soon as a strength is calculated by the program. To disable this feature, go to Tools/Options and find the selection on the General tab. To force the fracture type to be blank, enter a blank space.

- **Picking a Fracture Type from a List**
  If you know how a cylinder fractured, but forget which letter is which, right click on the fracture type field to display a sub-menu that lists the fracture types. Click on one of the fracture types listed to have it inserted for you.

### 4.5.12 Using Drop-Down Data Lists in the Break Table

Certain custom report forms are set up to use one of the break table fields for an extensive note such as "B) The 7 day result projects that the specified strength will likely be met at 28 days according to a typical strength:age relationship. (7 days)". To save the time of typing such a note repeatedly they can be stored in a dropdown list (see Section 3.3.6.1 for more details). This option is used primarily with custom forms.

### 4.5.13 Entering Break Data from a Break List

There is an easy way to enter break results that have been recorded on a break list printed by QC-Concrete. Select the option Edit>Enter Breaks from a Break List, click the Enter Break List Breaks button, or press Ctrl-B. Any of these actions will bring up the data entry screen illustrated in Figure 31:
Enter the peak loads in succession. If dimensions have not previously been entered, default values will be filled in for them, and the strength calculated. The type of fracture also has a default value. Set these default values by clicking on the Set Default Values button. Other data which can be entered are the Fracture Type and, for beams, the break notes.

If a strength is calculated that is less than the required strength, less than a younger specimen from the same set, or a 7 day break is less than a prescribed percentage of the 28 day design strength, a message (alarm) will appear. Set the percentage of the 28 day strength that triggers the alarm by clicking on Set Default Values.

Some custom reports include the Pass/Fail test result. This is automatically determined by the program by comparing the average strength with the required strength. Occasionally, a test may fail but reporting that it failed may not be desired. In that event, the Not Applicable checkbox may be checked, to override the program’s determination. Other custom reports allow overriding a failing test under ACI 318 criteria.

### 4.6 Shortcut Keys

To assist with certain frequently performed tasks the program has some shortcuts and local menus.

- **Find a Specimen:** Press Ctrl-F (The Ctrl key and the F key at the same time.)
- **Find Again:** Press F3 (Function Key F3.)
- **Enter Break List Data** Press Ctrl-B (The Ctrl key and the B key at the same time.)
- **Layout:** Point to a label or the break data table and right click. The layout menu pops up.
Data Entry

- **Cut, Copy and Paste:** Highlight (either with the mouse or shift/arrow keys) any Field Data or Break Data. Then point to the highlighted data and right click. A menu pops up that will let you Cut, Copy, or Paste.

- **Insert a Date:** Point to a date field (like date sampled or placed, if you are entering the data the same day it was sampled or placed) and right click. Right click a second time and get the option to insert a long, medium or short date.

- **Insert a Fracture Type:** Point to a fracture type field and right click. Click on a fracture type to have it entered.

- **QuickData:** QC-Concrete has a feature called QuickData, for lack of a better term, that allows frequently used phrases to be saved and quickly inserted when needed. If you find yourself frequently entering the same phrases over and over, use this feature to save time. Right-click on the data field twice to bring up the QuickData menu. The choices are Dates, and any user configured QuickData you have entered. The data will be appended to any data already existing in the current data entry field. If you select (highlight) the existing data first then QuickData will replace it instead of appending to it. See sections 4.4.3, 4.9, and 6.1.7 for more information.

- **Scrolling through data from previous tests:** To save time, any particular Field Data field can be quickly filled with data for that field from a previous test. When the data entry cursor is on any of the Field Data fields, press Ctrl [ or Ctrl ] to scroll backwards and forwards through the data.

### 4.7 Special Characters and Symbols

The key codes for special characters varies. They can be determined by using the Character Map program which is part of Windows. It is usually accessed from the Start Menu, with Programs > Accessories > Character Map. Once you have found the special character you want, you can copy it from Character Map and paste it in QC-Concrete. Special characters which are used frequently can be directly entered using the key code (Alt + Key Code).

**Example:** In MS San Serif, the degree symbol (°) is usually directly entered using Alt 0176.

### 4.8 Changing the Project Number, Report Number, or Date

Certain information for each test is used to uniquely identify the test. These are the Project Number and Report Number. If the selection method requiring dates is employed, then the Placement Date is also used to uniquely identify a test. The need may arise to change one of these values for a test, and since there are no formal data entry fields for Project Number, Report Number or Placement Date, they must be changed using Edit > Change a Report’s Project, Report Number or Date. This form is shown in Figure 32:
Some tips for changing these values are:

- **Project Number**: Select from available Project Numbers.
- **Date**: Select from available Dates, or enter a new date (if not using Dates this option will not be available).
- **Report Number**: Enter the new report number for the existing report.
- **OK and Cancel**: OK saves the changes, Cancel abandons the changes.

**Note:** To assign a different project number to an entire project select Tools>Administrator Tools. Refer to Section 9.8 for more information.

### 4.9 Report Data

Reports often include data which rarely changes, like the name and title of the supervisor who reviews and signs the reports. This information does not need to be entered every time, it is kept in the Report Data database for reuse every time a report for a particular test type is printed. Details about entering and using Report Data are in Section 6.1.7.

Report data also includes QuickData in the last 3 lists. For more information on using QuickData see Section 4.4.3 and Section 4.6.
Section 5  
Managing Mix Information

QC-Concrete keeps a database of mix information. Some custom reports use much more mix information than the standard reports do, and the Mix Database is where this information is maintained. Concrete Performance Report (CPR) reports also provide more mix information, so export facilities use the mix information. Also, when the Mix ID entered in the Field Data Section, the Design Strength for that Mix, the Principle Design Age, and Supplier are added to the Field Data. Up to 3 design ages and strengths can be entered. When break results are entered, the Percent of Design is calculated based on these ages and strengths.

To access the mix database click on the mix database button or select Tools, View, Mix Data. The data entry screen for the database looks like:

![Figure 33 – Mix Information Form](image)

What should be done with the Mix Database? Any frequently referenced mixes should have their specifications entered here. Only the Mix Number, Design Strength 1, Design Age 1, and the Principle Design Age are required by the basic report forms provided with the program. However, you should include any other information relevant to your custom report format. QC-Concrete Mix management options are discussed in the following sections.

**Note:** Users with custom forms may have the titles of the mix database fields customized to correlate better with the custom form. In these title need to be customized contact VES to have it done.
5.1 Mix Tools

- **Update Tests and Breaks:** When a change is made to a mix that is used by more than one test the user should always click on **Update Tests and Breaks** to scan the entire database for instances of this particular mix, and update the dependent information. This is critical if the change involves a required strength. This operation may be slow, so only use it if calculated values are dependent on the changed value.

- **Adding New Mixes:** Enter a new Mix ID in the Mix Number field or click on **Add New** in the Mix Tools frame.

- **Deleting Mixes:** Select the mix to delete then click on **Delete**.

- **Renaming Mixes:** Select the mix to rename then click on **Rename**, and enter the new name. This will find all the reports with the old mix number and change them to the new mix number as well.

5.2 Mix Reports

- **Print Current Mix:** Reports listing the information for a particular mix can be printed in two formats. Examples of these are shown below.

![Figure 34 - Format MIX1](image1)

![Figure 35 - Format MIX2](image2)

Select the format to be used by clicking the **Pick Format / Select Reports** button. Select the template using the dropdown list at the top of the form. See Figure 37.

- **Print Mixes for Selected Projects:** Reports listing the mixes used on a specific project/projects can be printed. The report will use as many pages as needed to include all of the mixes. An example is shown below.
Figure 36 - Example Report of a Project’s Mixes

To select which projects to report click on the **Pick Format / Select Reports** button. Then select projects from the project list. An example of the form used to select projects is shown below:

Figure 37 - Selecting Mix Report Templates and Projects for Project Mix Report
Section 6
Printing Reports

There are 5 categories of reports which QC-Concrete prints. These are:

1. Test Reports - The main type of report for submittal to clients
2. Break Lists - List all specimens scheduled to be broken on a specific day
3. Testing Summaries - Reports which summarize all breaks which meet certain criteria
4. Mix Reports - The specifications for a specific mix, or all mixes on a project/projects
5. Project Reports - Lists all active projects and pertinent information
6. Addresses - Not really a report, but a printing option covered in this section

This chapter explains selecting, previewing, printing, and creating PDF files for these reports.

6.1 Test Reports

Test reports are the main report printed by the program. They show project and field data and the strength results for each specimen broken. Envelopes may be printed following the reports.

6.1.1 Selecting Test Reports

Click on Reports > Report Selection to display the form that allows selection of which test reports to print. At the top of the form is the current selection method and the number of reports that meet the requirements of that selection method. This form is shown in the following figure:

![Appearance of Form for Choosing Report Selection Method]

The selection criteria are:
• **Use break, placement, or sample dates**: While breaks dates are the most practical criteria for selecting reports to print, the program allows selection using placement and sampling dates.

• **Currently selected report only**: The program only prints the currently displayed report.

• **Reports for a single date**: The program prints all reports which contain specimens with on the date specified. Change the date by entering a different date or clicking on the forward or backward arrows. Reset changes the date to the current date.

• **Reports for dates between (first date) and (second date)**: The program prints all reports which contain specimens with dates in the range of dates specified. Change the dates by entering a different date or clicking on the forward or backward arrows. Reset changes the date to the current date.

• **All unprinted new reports (XX new reports found)**: The program prints all new reports and then marks them as printed. They are only a new report once, adding break data does not make them a new report again.

• **Limit to project number**: The program only prints reports for the project specified.

• **Omit reserve specimens age (age)**: Check and enter the age of the specimens to ignore when picking reports by Break Date. Enter 0 to exclude any specimen with HOLD or SPARE or other text description entered for the age.

• **Omit reports with specimens older or younger than**: Check the box, select older or younger, and enter the maximum age (if omitting reports containing older specimens) or minimum age (if omitting reports containing younger specimens).

### 6.1.2 Other Report Printing Options

• **Print a report for each name on the distribution list?**: This allows the user to override the default setting for printing/not printing a report for each name on the distribution list. It does not change the default setting. See Section 3.3.9 for more information.

• **Include option to print envelopes following reports?**: Select this option to have the program print envelopes after printing the reports. See Section 6.1.5 for more information.

• **Always show this form before printing**: Check this box to always see the selection criteria before printing.

• **Export text file? (optional feature)**: Check this to export the selected reports to a tab-delimited text database instead of printing to a printer. This is an optional feature not included with the standard program.

• **Update**: After changing the selection criteria, press **Update** to determine the number of tests selected.

### 6.1.3 PDF Report Printing Options

• **Normal**: PDF’s (Adobe Acrobat Portable Document Format files) will be created for all reports whose projects are designated for PDF’s. Reports for projects not designated as using PDF’s will be sent to the printer.
• **PDF only**: PDF’s (Adobe Acrobat Portable Document Format files) will be created for all reports whose projects are designated for PDF’s. All other reports will be ignored (not printed).

• **Hardcopy only**: Ignores PDF designation on projects and sends all reports to the printer.

### 6.1.4 Printing Test Reports

To print a report or reports select *Reports* > *Print Test Reports*. All Reports meeting the Report Selection criteria will be printed. If a test has more breaks than the report template was designed for, it will print a second report (or more, until all that report's breaks are printed). Reports for projects that have the PDF file storage location set will not print at the printer. Instead, an Adobe Acrobat format PDF file will be created and saved at the location chosen for that project. See Section 3.3.2 for additional information about setting up PDF storage folders for projects. The file names are created using the Project Number, Report Number, and current date. As an example the PDF file name "2003-FC-0005_1_10-01-03.PDF" is from project 2003-FC-0005, report number 1, printed on 10/1/03.

**Note**: Each of the test types uses a specific report format. Information about changing the report formats is in Section 3.3.1.

### 6.1.5 Printing Envelopes Following Test Reports

One of the methods for printing envelopes is to print an envelope for each report, each project, or all reports and entries on the distribution list. To enable this method, check the box on the report selection screen to "Include option to print envelopes following reports". (See Section 6.1.3) After the reports are printed, the following form will appear:

![Envelope Printing Options Form](image)

**Figure 39 - Envelope Printing Options Form**

The program is set up for printing on standard 9½” x 4¼” envelopes, run through the left side of a laser printer, but can be modified for other sizes, just let GEOSYSTEM Software know what you need. There are several checkbox options when printing envelope sets:

• **Pause every XX envelopes**: When selected the program will pause each time a certain number of envelopes have been printed. Any number between 1 and 20 can be chosen using the More and Less buttons. Otherwise all envelopes will be printed at once.

• **Print only one envelope per project?**: If all reports for a given project/name on distribution list can be stuffed into a single envelope, select this to reduce the number of envelopes used.

• **Print envelopes for distribution list?**: For projects with a distribution list you can have envelopes printed for them as well. (Note: You should not select this if you printed reports for the distribution list, only if you did not - (See Section 6.1.3 for information about printing reports for the distribution list).
Another option is to Postpone printing envelopes until later. Choosing that option causes the program to save the current list of addresses in a text file for later recall and printing. The file has the name "_EnvList2_MM-DD-YY_HH-MM.txt" where the date and time are included in the file name. The file is saved in the program folder. Recall the file for printing using the menu option Reports > Print Addresses > Print Saved Set of Addresses. The same form will be displayed that is shown in Figure 39 - Envelope Printing Options Form, but with the following additional options:

![Figure 40 - Envelope Printing Options Form When Printing Saved Addresses](image)

Select the list to print from those listed then click on OK, the envelopes will be printed. You can keep the number of files in the list to a minimum by selecting the option to "Delete list after printing". Another way to eliminate unneeded address files is to select the file, then click on the Delete button.

**Note:** Also see Section 6.6 for additional information about printing envelopes and labels for a single report.

**Note:** Envelopes are printed on the left side of the printer, not centered.

### 6.1.6 Previewing the Current Report

To preview and print the current report click on the preview button, or select Reports > Preview Current Test Report. Just the currently displayed report will be previewed. The user can choose to print the displayed report directly from the preview screen. The preview looks like the following example:
When the preview screen is displayed you can:

- **Print**: Prints the displayed report on the currently selected printer.

- **Make PDF**: Creates a PDF file for the testing summary, viewable using Adobe Acrobat. The file will be saved in the default PDF storage folder if one is designated, otherwise it will prompt for a location, and the folder selected will become the default. See Section 3.3.2 for additional information.

- **Show previous/next pages**: If the report continues on subsequent pages, you may preview the subsequent pages/prior pages using the `←` and `→` buttons on this control.

- **Show first/last pages**: If the report consists of more than a few pages, you may go to the last/first page using the `↑` and `↓` buttons on this control.

- **Zoom in/out**: 

![Figure 41 - Report Preview](image)
Printing Reports

Change the magnification of the report by clicking on the magnifying glass or drop down the list of view magnification options. When zoomed, the area viewable can be adjusted by holding the left mouse button down and dragging the little hand the direction you want the report to move.

Note: If you get the error message "Nothing to do" it is probably because there are no reports which meet the selection criteria.

6.1.7 Report Data

Reports, especially custom reports, generally include information not specific to the test, i.e. the name of the reviewing person, their title, etc. This is information which generally doesn’t change from report to report, and is referred to as Report Data. The Report Data selected for a given Test Type on a particular project will remain set for all tests in the project unless changed by the user.

To change a value select Reports>Misc. Project Data>Report Data for this Project. Up to 16 Report Data items are displayed. The last 3, 14, 15, and 16 are also used for QuickData data entry of FieldData, see section 4.4.3 for more information. The data is on a form like in the following figure:
Figure 42 - Setting a Project's Report Data

Select from values previously entered or enter a new value. Some tips when working with Report Data are:

- New values entered become the default value for that Project and Test Type.
- To edit a value, select it, then make the changes. When finished hit Enter and you will be prompted to press "Y" to replace the original data with the edited version or to press "N" to add the changes as a new value.
- To abandon all changes, click on Cancel.
- To remove an item in one of the Report Data lists select the entry to be deleted then press F5. (It will be blanked out, not deleted, to preserve the position of the other entries.) To delete typing that hasn’t yet been added to a list, just select the typing and press Del.

Note: The titles of these data fields can be changed, so they may not look like this example. To change the titles refer to Section 0

6.1.8 Test Standards

Standards, such as ASTM, AASHTO, UBC or ACI test methods or specifications are usually referenced on reports as well, and generally don’t change often either. Information about which standards are referenced is called Test Standards. The Test Standards selected for a given Test Type on a particular project will remain set for all tests in the project unless changed by the user.

Specifications generally don’t change from report to report, but they can easily be changed prior to printing any particular report. The program keeps a set of default standards specific to that project. To change a value select Reports>Misc. Project Data>Test Standards for this Project, the program will display the Test Standards form:
Select from values previously entered or enter a new value. Some tips when working with Test Standards are:

- New values entered become the default value for that Project and Test Type.
- To edit a value, select it, then make the changes. When finished hit Enter and you will be prompted to press "Y" to replace the original data with the edited version or to press "N" to add the changes as a new value.
- To abandon all changes, click on Cancel.
- To remove an item in one of the Report Data lists select the entry to be deleted then press F5. (It will be blanked out, not deleted, to preserve the position of the other entries.) To delete typing that hasn't yet been added to a list, just select the typing and press Del.

**Note:** The titles of these data fields can be changed, so they may not look like this example. To change the titles refer to Section 9.10.2

### 6.2 Break Lists

Click on the Break List button, ![Break List Button](image) or select Reports > Break List to print a list of specimens due to be broken on a specific day. All the specimens scheduled for testing that day will be printed on a list. There are several user options to define what it means for a specimen to be scheduled. The following sections discuss procedures related to Break Lists.
6.2.1 Defining a Scheduled Specimen

A scheduled specimen may be defined as:

- All unbroken specimens up to and including the break date
- Unbroken and prematurely broken specimens for the exact break date
- Only unbroken specimens for the exact break date

Select your preference using Tools>Options then select the Other Reports tab. More information is in Section 3.4.

6.2.2 Picking a Date for the Break List

Pick a day from the choices offered before printing. The form for picking dates for the break list looks like Figure 44:

![Figure 44 - Selecting the Date for the Break List](image)

The list will be shown as a screen preview automatically before printing. There is no option to override this preview. When the preview is displayed click on the Print button to print the Break List. Click on Close to close the preview without printing. Refer to Section 6.1.5 for more information about previewing.

**Note:** If you need a break list for more than 2 days ahead or 1 day behind, use one of the last 2 options. There you can enter any date or the number of days, plus or minus (+ or -) from the current date.

There are numerous standard break list report formats. Many of these are minor variations of others which were added to meet the needs of a specific customer. Select the format desired using Tools>Options>Other Reports. Samples of some of these reports are shown here:
Figure 45 - Format BRKLIST1, basic

Figure 46 - Format BRKLIST2, landscape orientation

Figure 47 - Format BRKLIST3 shows Prior Breaks

Figure 48 - Format BRKLIST4 shows Prior Breaks and Specimen Type
Figure 49 - Format BRKLIST5, includes Project

Figure 50 - Format BRKLIST6, includes Required Strength

Figure 51 - Format BRKLIST7 shows Job No. and Report No.

Figure 52 - Format BRKLIST8 shows a Comment

For more information see Section 3.4
6.3 Testing Summaries

Testing Summary Reports print information about every specimen that meets the selection criteria. Select Reports>Testing Summaries to print a report summarizing test results. A wide variety of selection criteria are available to control which specimens are printed. A form for choosing selection criteria is displayed when this option is selected. An example of this form is shown in the following figure:

![Figure 53 - Test Selection Criteria for Testing Summaries](image)

Selection criteria options are explained in the following sections.

6.3.1 Testing Summaries, Date Criteria

If starting and ending dates are entered as criteria, the summary will only print specimens tested within that time frame. The dates can represent either the date placed or the date broken, depending on which option is selected. The date selection form is shown in the upper right hand corner of Figure 53.

6.3.2 Testing Summaries, Project, Mix and Test Type Criteria

In the Category of Selection Criteria box click on Project Mix and Test Type Criteria. Use these to limit the Summary Report to specific Projects, Mixes and/or Test Types. The selection form is the same as Figure 53, but the upper right hand corner changes to:
Select from the lists of Projects, Mixes, and Test Types the limiting criteria.

**Note:** Test Type defaults to Cast Cylinder, but can be set to none, meaning all Test Types qualify.

### 6.3.3 Testing Summaries, Lab Test Criteria

Summary reports can also be limited to specimens with specific values of lab test results such as Strength, Percent of Required, or even which technicians performed the break test. The limiting values for each of these criteria are entered right beside them. See figure below:

![Figure 55 - Selecting Lab Test Result Criteria for Testing Summaries](image)

Toggle between “less than” and “less than or equal to” by clicking on the symbol. Toggle “greater than” and “greater than or equal to” the same way. Also available is limiting the report to specimens of a certain age. Up to 5 discreet ages can be specified. "Hold" cylinders can be included by typing in the designation such as "HOLD" or "SPARE".

### 6.3.4 Testing Summaries, Field Test Criteria

Summary reports can also be limited to specimens with specific values of field test results such as certain ranges of Slump, Air Content, Temperature or specific Technicians performing the field test. The limiting values for each of these criteria are entered right beside them. See the figure below:
Figure 56 - Selecting Field Test Result Criteria for Testing Summaries

Toggle between “less than” and “less than or equal to” by clicking on the symbol. Toggle “greater than” and “greater than or equal to” the same way.

6.3.5 Sorting Criteria

Summary reports primarily print lists of specimens. The list can be sorted by Project Number, Report Number and Specimen Number or just by Specimen Number.

6.3.6 Test Selection Criteria Summary

As selection criteria are added, they are summarized in this area. Its purpose is simply to provide an easy confirmation that the criteria chosen were the ones desired. See figure below:

Figure 57 - Summary of Selection Criteria for Testing Summaries

6.3.7 Current Report Format

Select the report format desired. Various predefined summary formats are supplied with the program. They each include different details about the specimen. The following figures show some of the available formats, a more complete set, which numbered 30 as of 2006, can be found on the GEOSYSTEM website at

Figure 58 - Format SUMMARY1, includes Diameter and Area

Figure 59 - Format SUMMARY2, includes Report Number and Field Data

Figure 60 - Format SUMMARY3, landscape orientation including Field Data and Dimensions
A description is shown for each Summary Report Format (see Figure 53). Long descriptions will not be completely shown, to display more, click on the description and use the arrow keys to shift it left and right. There are now 15 summary reports, and more are being added all the time. For examples of all new summary reports visit GEOSYSTEMSoftware.com.

### 6.3.8 Testing Summaries Export Text File

An optional feature is to create a tab delimited text file suitable for spreadsheet import. To do this check the Export text file? checkbox. When exporting there is no printer output, only a file created with a name “SummaryReport” followed by the range of dates summarized and “FFW.TXT”: To import the file into a spreadsheet or other database follow the directions for that software for importing tab delimited text files.

### 6.3.9 Testing Summaries Print and Preview

To print the Testing Summary, click on the Print button. To preview before printing, click on the Preview button. The Preview form has the appearance illustrated in Section 6.3.7 When the Testing Summaries Preview is displayed the following options are available:

- **Print**: Prints the displayed test summary on the currently selected printer.

- **Make PDF**: Creates a PDF file for the testing summary, viewable using Adobe Acrobat. The file will be saved in the default PDF storage folder if one is designated, otherwise it will prompt for a location. See Section 3.3.2 for additional information.
• **Show previous/next pages:** [2 4] If the report continues on subsequent pages, you may preview the subsequent pages/prior pages using the [and ] buttons on this control.

• **Show first/last pages:** [2 4] If the report consists of more than a few pages, you may go to the last/first page using the [and ] buttons on this control.

• **Zoom in/out:**

  Change the magnification of the report by clicking on the magnifying glass or drop down the list of view magnification options. When zoomed, the area viewable can be adjusted by holding the left mouse button down and dragging the little hand the direction you want the report to move. Double click on the report for the next larger zoom setting.

### 6.4 Mix Reports

Mix Reports list the information for a particular mix, or the information for all mixes used on a project or set of projects. See Section 5.2 for additional information.

### 6.5 Project Reports

Project reports are simple lists of the contents of the QC-Concrete project database. That database contains the information specific to each project, such as Client, Company, Distribution List, etc. Up to 4 project database fields are shown on each line of the report. There are 5 project report templates included with the program. To print a project report, select *Reports > Project Report*. The form displayed lets you pick which project report template to use, which column to sort on, and whether or not to include inactive projects:
Whichever database field is in the first column will be included in the report without duplicates. While there won't be duplicate project numbers (or at least there shouldn't be...), there will be duplicate clients. For instance, if the Client Company (CCOMP) is in the first column, that company will only appear once on the list, even if there are several projects in the database for that client. Examples of the 5 standard reports follows:

Figure 63 - Project Report Options

Figure 64 - Heading of Project Report PROJECT1.PRП

Figure 65 - Heading of Project Report PROJECT2.PRП
6.6 Printing Addresses

QC-Concrete can print envelopes or labels for all or part of the distribution list for a single report, or envelopes for a set of reports. Printing envelopes for a set of reports is a recent addition to the program as was not integrated with the old single report envelope and label printing routine discussed here. For information about printing envelopes for a set of reports refer to Section 6.1.5 for additional information. To print labels or envelopes for a single report select Reports > Print Addresses to display the address selection screen, see the figure below:
Figure 69 - Envelope and Label Printing of Addresses

Check the recipients which should be included, or Select All. If there is no data for the recipient, you will not be able to check it. Click on the radio button for either Print Labels or Print Envelopes. Some notes about these two options follows:

- **Printing envelopes:** The only envelope printing technique currently supported is landscape printing on a laser printer.

- **Printing labels:** The only label printing technique currently supported is on 30 labels per sheet size laser printer labels. The program will print all the addresses selected, and then start over, continuing until 30 addresses have been printed. If you are printing 10, 6, 5, 3, 2, or 1 addresses, an even number of sets will be printed on one sheet of labels. Otherwise, the last set printed will be incomplete.

6.7 **Printer Setup**

The Printer Settings window is opened by selecting *Reports > Printer Settings*. It displays the printer selection dropdown list as well as some information about the printer which can be derived from the printing subsystem. The printer selected in this way becomes the system printer for all programs using that particular PC. Be sure to change it back if the selected printer is only a temporary selection.
6.7.1 E-mailing Reports

QC-Concrete does not offer a direct E-mail option, however there are 2 common techniques which work.

- **Print to File:** Selecting the print to file option allows you to create a data file which can be e-mailed and then copied to a printer of the same make and model. The recipient should use the DOS command COPY /B FILENAME.PRN PRN to complete the printing. If you have questions about this contact your office computer expert for help, please do not call GEOSYSTEM Software.

- **Create PDF files:** You can print reports to "Adobe Acrobat PDF" format files which can then be e-mailed. Most computers have Adobe Acrobat Reader, however, if your recipient does not, they will need to obtain it. The Acrobat Reader program is widely distributed free of charge by Adobe, available at their website. For more information about creating PDF files with QC-Concrete refer to Section 6.1.3

6.7.2 Faxing Reports with Modem

If your computer has a fax software installed, select the fax printer device as the printer to be used. Then use the fax software as directed in its instructions.
Section 7
What To Do With Old Projects

QC-Concrete allows the user to designate a project as inactive, and further, to archive that inactive project to a separate database. An inactive project is still in the QC-Concrete database (the file name QC-Concrete.MDB), and it will still be a source of data for statistical exports, but none of its tests are visible or accessible in normal program use. An archived project is completely removed from the QC-Concrete database, in a database file of its own. Archived projects may be returned to the QC-Concrete main database if needed.

Access these options using Edit > Project Status. The form used to manage Inactive Projects looks like the following figure:

![Figure 70 – Inactivating and Archiving Old Projects](image)

7.1 Inactive Projects

With this status, the project remains in the database, but does not appear in lists of projects. Data from inactive projects may be optionally included in data files exported for statistical analysis by CPR, the GEOSYSTEM Concrete Performance Report program.

When would you want to make a project inactive? After a project is finished, and there is no longer any need to recall it, all it is doing is adding to the length of the Project Number selection list. However, some of the test data may be useful for statistical analysis, so it should be made inactive, but not archived. To make projects Inactive or Active, do the following:

- **Giving Inactive Status to a Project:** To make a project INACTIVE, click on it to highlight it in the Active (right) list, then click on the arrow toward the left.

- **Giving Active Status to a Project:**
To make a project ACTIVE, click on it to highlight it in the Inactive (left) list, then click on the arrow toward the right.

- **Updating Inactive Status of Projects:**
  Early version of QC-Concrete did not mark reports and specimens inactive. As more features were added to the program it was necessary to begin tagging individual tests and individual specimens as inactive as well as projects. The Update button was added to perform an audit of the database and insure that all records belonging to an inactive project were also marked as inactive.

### 7.2 Archiving and Retrieving Projects

Older projects which are no longer of interest may be completely eliminated from the database by Archiving them. Why would you want to archive a test? Archiving reduces the number of tests in the database and improves overall performance while reducing database file size. Also, for convenient record keeping, you may wish to archive the project to the GEOSYSTEM for Windows project folder (PROJECT.GEO). Tests in archived projects are no longer available for statistical analysis, however. Archived files may be retrieved, reincorporating them into the master database.

- **Archiving a Project:**
  Any inactive project may be archived, saving all the tests in that project to a separate database file, and removing them from the main database file. To archive a project, click on it in the Inactive Project (left) list, then click on the Archive Project button. Select a location and filename for the archived project, and the project will be archived. Be sure to select a standard (short, 8 character) filename with the .MDB extension. Long filenames will be rejected by the program.

- **Retrieving a Project:**
  Any archived project may be retrieved, inserting all the tests in that project to the main database file. The archived file is left alone, so the project is essentially in two databases. After changes or additions are made to the project that was retrieved it can be re-archived to the same database file.

  During project retrieval, a report being retrieved may be found to already exist in the database. QC-Concrete will do one of 3 things when a duplicate is found:

  1) To have prompts for a confirmation that the existing report should be replaced by the one being retrieved, check the first option "Confirm replace".

  2) If it is known in advance that all existing reports are to be replaced, before retrieving the project, check the option "Always replace" at the bottom of the form.

  3) Finally, if duplicate projects are never to be replaced from an archived database, select "Never replace." This option is useful when 2 main databases need to be merged.

  **Note** that the Mixdata Table is never included in the merge - mixes which exist in the archived database are ignored.

### 7.3 Merging Branch Databases

In cases where a company's home office needs to keep a branch office's tests with theirs, QC-Concrete allows you to merge one database into another. After receiving the database to be merged, save it in a location accessible to QC-Concrete. Then select the menu option **Edit>Project Status**. Then click on **Merge Branch Database**. Navigate to the QC-Concrete database to be imported and select it. QC-Concrete merges the entire branch office database; all projects, reports, specimens and mixes.
In order to use feature your method of identifying a report’s specimens must require unique specimen numbers. (Needed because if a branch office changes the specimen information on some report there is no ambiguity about which specimen in the home office database needs updating). Because of this the QC-Concrete program option to require unique specimen numbers in reports must be selected. See Section 0 for more information about requiring unique specimen numbers in reports.
Section 8
Exporting Results for Statistical Analysis

GEOSYSTEM Software has a product called Concrete Performance Report (CPR). It is a DOS based program which performs statistical analysis on concrete test results and prints reports and charts. Eventually, CPR will be converted to the Windows platform and tightly integrated with QC-Concrete. Until then, users who have CPR and need to perform a statistical analysis on data stored in QC-Concrete can use this facility to extract the needed data from QC-Concrete and save it in a format which can be used by CPR. Select Tools > Export to CPR to access this facility. The export form has the following appearance:

![Figure 71 – Exporting Results for Statistical Analysis](image)

Details about how to export to a CPR file are in the following sections.

8.1 CPR Export Criteria

In order to selectively export test results for statistical analysis, QC-Concrete allows selection based on several criteria. These include:

- **Date Criteria**: If starting and ending dates are entered the export file will only contain specimens tested within that time frame. The dates can represent either the date placed or the date broken, depending on which option is selected.
• **Project, Mix and Test Type Criteria:** Use these to limit the statistical analysis to specific Projects, Mixes and/or Test Types.

• **Field Test Criteria:** CPR export files can also be limited to specimens with specific values of field test results. I.e. certain ranges of slump or specific technicians performing the field test. The limiting values for each of these criteria are entered right below them. Toggle between “less than” and “less than or equal to” by clicking on the symbol. Toggle “greater than” and “greater than or equal to” the same way.

• **Ages to be Exported:** CPR has 2 analysis modes, three 28 day specimens or one 7 and two 28 day specimens per test. If you are only using 2, 28 day specimens per test you should select the one 7 day and two 28 day option.

• **Test Selection Criteria Summary:** As selection criteria are added, they are summarized in this area. Its purpose is simply to provide an easy confirmation that the criteria chosen were the ones desired.

### 8.2 CPR Export File Names

• **Exported File Name and Path Name:** You must export the data to a file in the CPR program folder. Any standard 8 character name can be used, QC-Concrete will add the file’s name to the CPR file name index and create the .PDT (project data file) and .TDT (test data file).

  **Note:** It is often convenient, when routinely doing statistical analysis on the same mix or project, to export to the same filename each time. You will need to confirm that it is OK to overwrite the previous file.

• **Existing CPR Project File to Copy:** If a CPR file exists which contains all the project and mix information that you would like to report in the new statistics report, enter or browse to the existing CPR project file. When would you want to use an existing CPR project file? Many large construction projects require the periodic statistical analysis of concrete. Using the CPR project file created the first time statistics are done will save time.
Section 9
Administrator Tools and Multi-User Capability

The Administrator Tools are used for a number of infrequently performed tasks:

1. Status and maintenance of the program’s multi-user capability
2. Checking database statistics such as number of reports or projects
3. Viewing or changing the last specimen number automatically provided by the program
4. Importing data from DTRC when updating from the old Daily Test Report for Concrete program
5. Examining and maintaining the entire database (password protected)
6. Displaying a list the add-ins licensed
7. Changing the location of the database
8. Renaming a project
9. Setting the report selection mode.

Each of these tasks is described in more detail in the following sections.

9.1 Multi-User Status

Multiple users may access the QC-Concrete database at the same time. All users have the same rights, and identical fields may be edited simultaneously. When two users have been editing the same field, the last one out wins. Tabbing past fields which have been changed by another user causes the screen display to refresh, and the new data be displayed. So it is recommended that if you have more than one user changing test data they should stay in different reports.

In a multi-user environment it may be helpful to know if other users have the database open. A message can appear at startup to notify the user of that case. To enable the message, select Tools > Options and on the General tab, click where it says Enable “Program in Use” warning at startup. Note that when enabled, the message may also be triggered by running the program after a program crash.

When other users are active, their identity is included in the list at the top of the Administrator Tools form. If the list includes names of users who are not actually active, then they somehow closed their last session with the program without having their name removed from the list. That probably indicates a program crash occurred, and you should notify us about it.

Note: To remove a user’s name from the list when they should not be on it, right click on the name and select Delete.
9.2 Database Statistics

The QC-Concrete database is a group of 4 databases, called Tables. The 4 tables are listed on the Administrator Tools form. To determine the number of records in each table the program must open each table, then move to the last record, which may take a few moments depending on the size of the database. Click on Count Records to run the record count.

9.3 Last Specimen Number Used

When the option to have QC-Concrete suggest the next specimen number based on the specimen number counter is used, the last specimen number is displayed here. It can also be changed here. Click on Edit to initially set or change the value of the last specimen number used. See section 3.2.3 for more information about options for QC-Concrete automatic specimen numbering.

9.4 Importing from DTRC

QC-Concrete can import data from old, DOS Version, GEOSYSTEM Daily Test Report for Concrete (DTRC) databases. The import process involves 2 procedures, one with DTRC, the other with QC-Concrete. These procedures are described in Appendix A.

9.5 Database Maintenance

In the database maintenance frame there are 2 functions - one for assistance in technical support and the other for disabling the automatic backup feature. They are explained here.

- **Examining the entire database (the Edit button):** This may be used as an aid during tech support calls. You will receive special instructions from GEOSYSTEM Software when this is needed. It is password protected so inadvertent access, and the risk of data loss, is prevented.

- **Create a backup of the database each time the program starts:** To have the program make a copy of the database each time it starts, check this box. It can be useful if the database gets damaged while in use and has saved the day on a number of occasions over the first few years that the program was in use. This option is offered as a safety net for users who like to take every precaution with their databases. If you are one of those, use it, however it also slows down the loading of the program.

When the backup is created, it is not simply copied. The database goes through and inspection and improvement process which removes unnecessary extra space and corrects any file format problems which are found.

**Recommendation:** Activate this option once a week for one day. This will keep your database in top condition for maximum efficiency and minimum size.

- **Other Backup Recommendations:** Please back up your database frequently (every day if possible). To do so, copy the file CQC-CP.MDB to a backup location. Refer to Section 9.7 for more information about where to find CQC-CP.MDB. A better procedure is to include the entire QC-Concrete program folder in your backups. This is the best way to prevent significant downtime. Ask your office computer expert for assistance with setting up efficient, automatic backups.
9.6 List of Add-Ins Installed

If the Break Importer or Client Importer options have been installed they will be checked.

9.7 Database Location

In rare circumstances an alternative location for the database may be preferred. If needed, access it using Tools > Administrator Tools. The current path, new path, and ways to navigate to the new folder are provided as show in the following figure:

Figure 72 - Selecting a Path to the QC-Concrete Database

To select the new folder, first select either a drive or a network location.

- Select the drive to use. Network drives must be mapped to a drive letter to show up.
- or Select the network location.
- then Select the folder to use. After selecting a new location the program will automatically terminate when you exit the Administrator Tools form. When QC-Concrete is next started it will reference the new database location.

Note: If you selected a folder that does not have a copy of the database in it, it will be moved to that folder. Otherwise it will simply reference the new location. If you have more than one QC-Concrete database it may be confusing, so have multiple databases only if there is good reason.
9.8 Renaming Projects

In the event that a project has been given the wrong project number, and tests have been entered, this option is available to correct the problem. Enter a new, unique name here, and the program will change all database references to the old project number to the new project number.

9.9 Report Selection Mode

How tests are selected depends on your company’s convention for identifying tests. Typically this is done one of three ways:

1. All tests are uniquely numbered, there is no duplication even between different projects.
2. Tests are numbered sequentially from the start to the finish of the project, so all report numbers in a project are unique.
3. Report numbers start over at one every day, so the placement date becomes essential to uniquely identify a test.

The following examples illustrate 8 tests, identified each of the 3 ways.

<table>
<thead>
<tr>
<th>All Test Numbers Unique</th>
<th>Tests Numbered Sequentially Start to Finish for Each Project</th>
<th>Test Numbering Starts Over Each Day</th>
</tr>
</thead>
<tbody>
<tr>
<td>PROJECT NUMBER</td>
<td>DATE PLACED</td>
<td>TEST NUMBER</td>
</tr>
<tr>
<td>01234</td>
<td>1/1/00</td>
<td>1</td>
</tr>
<tr>
<td>01234</td>
<td>1/1/00</td>
<td>2</td>
</tr>
<tr>
<td>01234</td>
<td>1/1/00</td>
<td>3</td>
</tr>
<tr>
<td>56789</td>
<td>1/1/00</td>
<td>4</td>
</tr>
<tr>
<td>56789</td>
<td>1/1/00</td>
<td>5</td>
</tr>
<tr>
<td>01234</td>
<td>1/2/00</td>
<td>6</td>
</tr>
<tr>
<td>01234</td>
<td>1/2/00</td>
<td>7</td>
</tr>
<tr>
<td>01234</td>
<td>1/3/00</td>
<td>8</td>
</tr>
</tbody>
</table>

Example 1 – Three Ways Labs Identify Cement Products Tests

The first two methods are treated alike by QC-Concrete while the third method gets its own data entry procedures. The following sections explain how to make QC-Concrete fit each of these report selection methods.

To set the program up for the methods where all test numbers are unique or where they run sequentially each project start to finish select Tools > Administrator Tools. Beside "Use Placement Date in report selection (so report numbers can start over daily)" select the option "No".

When this is selected, the selection section of the data entry screen looks like the following example:

Figure 73 - Test Selection Panel When Dates Are Not Used
9.9.1 Tests Numbering Starts Over Each Day

To set the program up for the method where test numbers start over each day select *Tools* > *Administrator Tools*. Beside "Use Placement Date in report selection (so report numbers can start over daily)" select the option "Yes".

When this is selected, the selection section of the data entry screen looks like the following example:

![Figure 74 - Test Selection Panel When Dates Are Used](image)

9.10 Report Data and Standards Titles

Report data are those bits of information on reports, like the supervisor's name, which don't change from report to report. Standards, likewise, are the references to ASTM or AASHTO procedures which are usually included on reports. These don't change from report to report for a given test type either. They may, however, on occasion, need to be changed to provide for flexibility on custom reports. There are 16 of these items for Report Data and 16 for Standards. The titles for these items (on the left in the Figure 75 below) can be changed. See Sections 6.1.7 and 6.1.8 for information about how to use Report Data and Specifications.

Please note that changes to these titles do not appear on the printed report form. Only changes to the data entered beside the titles are seen on the report form. The field titles on report templates are factory configured, and can be customized by GEOSYSTEM upon request on a fee basis. Contact us if you are interested in custom forms with different titles for Report Data items.

9.10.1 Selecting the Report Data Titles to be Used With a Test Type

Changes are made to the Report Data Titles on the Report Data form when displayed specifically for changing the titles. This form displayed for changing its titles, looks like:
Figure 75 - Configuring Report Data Titles

When might you expect to need to change a Report Data Title? Probably only for custom forms which are created for you. In that event, select a test of the test type of interest. Next select Tools>Administrator Tools then click on the command button labeled Change Report Data Titles. Editing the titles is done by clicking on the title to be changed, then editing. Some other functions of this form are:

- **Copy Titles/Paste Titles:** Each Test Type has its assigned report, and likewise its own set of General Report Data. To copy all of the titles from one Test Type to another, click on Copy Titles, then OK, then exit Administrator Tools and then select the Test Type which is the destination for the set of titles. Go to Tools>Administrator Tools again and click on the command button labeled Change Report Data Titles again and click on Paste Titles.

- **Abandon:** Closes the form and discards all changes made since the form was opened.

- **QuickData Titles:** The last 3 Report Data items (14, 15, and 16) may be used for QuickData. If using QuickData, enter titles appropriate for the category of data being saved in the list.

9.10.2 Selecting the Standards Titles to be Used With a Test Type

The standards data form, when displayed for changing standards titles, looks like the one used for Report Data, shown in Figure 75.

When might you expect to need to change a Report Data Title? Probably only for custom forms which are created for you. In that event, select a test of the test type of interest. Next select Tools>Administrator Tools then click on the command button labeled Change Standards Titles. Editing the titles is done by clicking on the title to be changed, then editing. Some other functions of this form are:
- **Copy Titles/Paste Titles**: Each Test Type has its assigned report, and likewise its own set of General Report Data. To copy all of the titles from one Test Type to another, click on Copy Titles, then OK, then exit Administrator Tools and then select the Test Type which is the destination for the set of titles. Go to Tools>Administrator Tools again and click on the command button labeled Change Standards Titles again and click on Paste Titles.

- **Abandon**: Closes the form and discards all changes made since the form was opened.
# Section 10
## Troubleshooting

### 10.1 Error messages

These are some of the program's error messages. There are actually many more that may occur of the generic form "Error [error number] [error description] in [procedure name]. Just call about those. The table below is sorted alphabetically, the ones that start with a file's name will be among the first 11 or so.

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Remedy</th>
</tr>
</thead>
<tbody>
<tr>
<td>[file name] The disk on which this file resides cannot be accessed: insert the appropriate disk.</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] Bad File Name Specified</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] Device unavailable error when attempting to access the above file.</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] I/O error attempting to access the above file.</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] The above file was not found.</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] The disk on which this file is being saved is FULL!. Use File Manager or DOS to delete unused files from the disk, then switch back to this task and select Retry. (Select Cancel ONLY if you cannot recover any disk space.)</td>
<td>Free up some disc space.</td>
</tr>
<tr>
<td>[file name] The following error occurred while accessing the above file:</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] The path where this file should be located cannot be found.</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] This file is damaged.</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] This file, or the disk on which it resides, is in use or write-protected.</td>
<td>Contact tech support.</td>
</tr>
<tr>
<td>[file name] Too many files are open. Close any other tasks currently running, then switch back to this task and select Retry. (Select Cancel ONLY if you still cannot continue.)</td>
<td>Reduce the program load on your PC.</td>
</tr>
<tr>
<td>A database field [field name] required by this report is missing. Continue anyway?</td>
<td>Ok to continue on through, but call tech support for a replacement report template.</td>
</tr>
<tr>
<td>BrkLayout error in txtInput_LostFocus</td>
<td>call tech support</td>
</tr>
<tr>
<td>Could not begin printing, if you are printing over a network make sure the printer you have selected is available</td>
<td>The program could not print, try other applications to see if they can print, or make a different printer your default printer.</td>
</tr>
<tr>
<td>Could not create backup, contact VES, Inc.</td>
<td>You may be low on disc space</td>
</tr>
<tr>
<td>CourierNew and Arial are required to print standard reports. Refer to FAQ's for suggestions, Continue anyway?</td>
<td>Ok to continue on through. Two fonts which are typically on every PC are not on your PC. Have your PC specialist install them.</td>
</tr>
<tr>
<td>QC-Concrete appears to be currently in use by someone else on your network. This user is performing some task which requires exclusive use of QC-Concrete. Click OK to Exit. Note: If you believe this message to be in error you can click Cancel and correct errors in the user list after the program starts using Administrator Tools.</td>
<td>You cannot start QC-Concrete if another user is creating a new report. Start the program again momentarily, as the other user will probably be done within a few seconds.</td>
</tr>
<tr>
<td>QC-Concrete appears to be currently in use by someone else on your network. Click OK to join the other user. Click Cancel to Exit (if you do not wish to join a multi-user session). Note: You can list all users (and correct errors in the user list) after the program starts using Administrator Tools.</td>
<td>This is just an advisory message. Ordinarily you will just click OK and join the other user. If there is no one else using the program and you get this message then you should list all users (and correct errors in the user list) after the program starts using Administrator Tools.</td>
</tr>
<tr>
<td>QC-Concrete can't find [data folder name] because the drive is not ready. Click OK to switch to [program folder name] or Cancel to Quit and reconnect the drive for [data folder name]</td>
<td>A mapped network drive letter may have been disconnected.</td>
</tr>
<tr>
<td>QC-Concrete can't find [data folder name]. It may have been deleted. Click OK to switch to [program folder name] or Cancel to Quit and re-establish the existence of [data folder name]</td>
<td>The database was not found where it had been the last time QC-Concrete was run. Return the database to its previous location then allow the program to move it to a new location.</td>
</tr>
<tr>
<td>QC-Concrete can't find [database name] Click OK to browse for a database location or Cancel to Quit and troubleshoot [alleged database location]</td>
<td>The database was either moved, deleted, or corrupted. If you know it was moved, click OK and browse to the new location. If there has been no change, to the best of your knowledge, click Cancel, and navigate to the database folder to determine if CQC-CP.MDB is still there. If it is, and simply can't be read, e-mail it to <a href="mailto:Support@GEOSYSTEMSoftware.com">Support@GEOSYSTEMSoftware.com</a> to check it out. If it can't be found or can't be fixed, see if the backup database (~CQCPTMP.MDB) is in the program folder. If it is you can revert back to it by copying it to the designated database location and renaming it CQC-CP.MDB. You will lose all work performed with the program since the last time it was started with the &quot;Backup database&quot; option turned on.</td>
</tr>
<tr>
<td>Error archiving: [Error number] [Error description] Note that long filenames are not supported. See help for more information</td>
<td>Occurs when the program is archiving, call tech support</td>
</tr>
<tr>
<td>Error finding projects in [folder name]</td>
<td>The GEOSYSTEM Data Manager project folder selected is not the correct one</td>
</tr>
<tr>
<td>Error importing data for: [type of import] Data not in expected format, first line: [first line of data read] Expected: [example of what was expected]</td>
<td>call tech support, or send the client database which caused the error.</td>
</tr>
<tr>
<td>Error reading network share</td>
<td>Verify your network is OK</td>
</tr>
<tr>
<td>Error: [error number] / [error description] Try changing to a different default printer and then changing it back</td>
<td>Sometimes the printer object is not refreshed without a change in the printer device. Change to a different printer then change back.</td>
</tr>
</tbody>
</table>
Extension must be .MDB

Failed to CompactDatabase: [temp database name] and create: [main database name] Error: [error description]
Report this problem to VES, Inc. at 970-223-8788

This indicates the program was unable to perform routine maintenance on the database. You will need to copy the backup Programfolder\CQCPTMP.MDB as Datafolder\CQC-CP.MDB. See Section 9.5 for more information.

No Bold or Italic for Font [font ID] [error number] [error description]
The report template being used is damaged.

No Font [font ID] [error number] [error description]
The report template being used is damaged.

No Font in Collection: [font ID] [error number] [error description]
The report template being used is damaged.

No Size [size selected] for Font [font ID] [error number] [error description]
The report template being used is damaged.

Not a valid QC-Concrete database
When selecting a database to archive from the file must be a Microsoft Access format database

The calculations for this test type are not set up correctly for KEY= [calculation key name]
The break table settings for that test type are no longer correct. Refer to section 3.3.6.1 for information about how to reset the calculations.

The date: [date] entered for: [date filed name] wasn't clear to the program. Enter dates in a format like 2/22/02 for February 22, 2002, etc. for best results
Use the required date format.

The folder [new folder name] does not exist, changing to [program folder name] (the program folder)
When selecting the new location for the database the location was not accessible by the program.

Unexpected blank date encountered
Use the required date format.

Windows is unable to read drive [drive letter]
Make sure the drive door is closed and the disk is formatted and free of errors.

Your printer driver cannot provide required information. The best fix is to get current drivers from the company's web site or from your dealer.
Update your Windows printer driver

10.2 Minimizing Downtime

Every effort has been made to make this software as reliable as possible, however errors will occur. To minimize downtime, always call when an error occurs. We frequently update this software, usually based on information we get from our customers.

Also, back up your database daily, in the unlikely event of a catastrophic failure, your database is the only thing that cannot be restored by us. It is an even better idea to back up the entire QC-Concrete program folder, so if any updates/revisions have been added that are not on your original program CD, they can be restored. Talk to your office computer experts about establishing backup procedures. They are the best precaution against significant downtime, and if implemented and automated correctly, will not take any of your time. Refer to section 9.5 for more information about how and what to back up.
Appendix A
Importing Tests from the GEOSYSTEM Daily Test Report for Concrete program

QC-Concrete can import data from old, DOS Version, GEOSYSTEM Daily Test Report for Concrete (DTRC) databases. The import process involves 2 procedures, one with DTRC, the other with QC-Concrete. These procedures are described in the following sections.

A.1 Preparing the DTRC Database

1. A program named DTR2CQC.PRG is included with QC-Concrete to help prepare DTRC for import. Copy it from the QC-Concrete folder to the DTRC folder.

   **Note:** If the folder the program is in is unknown, search for it with Windows Explorer, using the Search or Find facility. Or locate it using DOS by going to an MS-DOS prompt. (Usually with Win 95/98/2000 you navigate Start, Programs, MS-DOS Prompt), then enter CD C:, then enter DIR VPI.EXE /S, then wait while the computer searches for VPI, the database program for DTR. When it finds it you will see something similar to, but not exactly like:

   ![MS-DOS prompt screenshot]

   The part that says “Directory of C:\CONCRETE\DTRC” is the DTRC folder.

2. Open an MS-DOS prompt, (see note above for help with the MS-DOS prompt).

3. Change to the folder the program is in by entering the DOS command CD C:\(path to program). For example, CD C:\CONCRETE\DTRC. The same path to the DTRC folder used in step 1.

4. Enter the command VPI. The program VPI will start and give you a 1> prompt.

5. At the 1> prompt type the command DO DTR2CQC. The VPI program looks something like:
6. Press enter, when it starts it should look like this:

Select "PROCEED TO CREATE CQC PROJ.DBF"

7. The program will display the current DTRC Project Database name:

Make a note of the specimen database name, then convert your current database by pressing 1.

8. The program creates a new database, based on the current database, then displays the steps required to modify the duplicate database CQC PROJ.DBF so it can be read by QC-Concrete:
Either print the directions at this time, or write down the Sample Database (aka Specimen Database) name for future reference. If you have a network printer and are not currently capturing LPT1, you may have problems printing this, in which case write it down, if you have not already done so. If it reports a mix database, make a note of its name too. Mix databases are a rare customization, it is unlikely that one will be found.

9. Select Exit, then start VPI again. At the "l>" prompt enter the command USE CQCPROJ, then the command MODIFY, then press END. At that point the screen should look something like:

10. Press "3", and the conversion process is complete. Your DTRC database is now ready to import into QC-Concrete.

A.2 Import the DTRC Database into QC-Concrete

1. Decide about importing the Sample Date as the Sample Date. Yes, this is a little confusing, so read up in Section 3.2.12 about Option to Add Sample Date.

2. Select Tools>Administrator Tools>DTRC Import and click on the Import button. The following screen will be displayed:
3. Select the DTRC Project Database (always CQCPROJ if you followed the directions above) and Test (aka Sample or Specimen) Database. You should have written down the name when performing the steps in A.1. If yours is a custom DTRC, you may have a mix database too, if so, enter the name now as well. You should use the name recorded when performing the steps in A.1.

4. After the DTRC Project Database has been selected the projects in it will be listed, click on the project to be imported. Shift-click to select a range, control-click to select multiple, individual projects. To select all projects, click on the first one, then scroll down to the last one and shift-click on it.

5. QC-Concrete has a larger and somewhat different database structure than DTRC. This requires mapping a correspondence between DTRC data fields and QC-Concrete data fields. This would not be a big problem except for the large number of custom programs with custom structures. If you have a custom program you should check and adjust the fields before importing. Check the field maps for all 3 databases (4 if DTR2CQC reported a mix database). Checking the field maps means looking for any obvious mistakes. Check each map by clicking on the database name, then clicking on Show Field Map. I.e. the Project field map will look something like:

![Field Map](image)

Problems will look very obvious, like CLIENT and PROJECT on the same line. To change a map, first delete the existing map then add the correct map. Deleting and adding maps are done by:
• **To Delete Fields from the Map:** Scroll the map window so the fields to be re-mapped are displayed. Highlight it (by clicking on it), then click on the button **Delete Fields From Map** and the correlation between the two fields will be dropped.

• **To Add Fields to the Map:** Under the heading **QC-Concrete Fields**, find the QC-Concrete field name to map (it will not have a corresponding DTRC field to the left of it). Click on it to highlight it. Under the heading **DTRC Fields……Sample Data** there is a dropdown listbox. Drop the list down (click on the down arrow) then find the DTRC field to be added to the map. It should be designated "not in use". Click on it. Click on the button **Add Fields To Map** and the two selected fields will be added as mapped to one another.

• **Maps all goofed up?** Click on **Cancel** to abort any changes.

**Note:** If you have already imported a project and the fields did not match up well, archive the project to a junk database (see Section 7.2 for how to do this), adjust the field map, then import again.

• **Option to Add Sample Date** - When importing data from a DTRC database (the old GEOSYSTEM Concrete program) there is usually nothing to transfer into the Sample Date field. This is because the DTRC database Sample Date is inserted as the QC-Concrete Placement Date, unless there is an actual DTRC Placement Date field. Most DTRC databases do not have a Placement Date field. You may wish to have the DTRC database Sample Date inserted as the QC-Concrete Sample Date as well. If this option is NOT selected, QC-Concrete will import the DTRC Sample Date only as the QC-Concrete Placement Date, and will leave the QC-Concrete Sample Date empty.

Select this option in most cases. When wouldn't you want this selected? Only if you have a lot of DTRC tests which were sampled **after** they were placed, like cored or sawed specimens. For these the DTRC Sample Date is not the same as the QC-Concrete Sample Date, and to have the DTRC Sample Date automatically inserted would give you incorrect values for Sample Date for those tests.

6. When the maps look OK, select **Start Conversion**. If the **Start Conversion** button is not available, no project has been selected.

**Note:** The import process will change QC-Concrete to the "Test Numbers Start Over Every Day" mode of operation. It does this because that is how most DTRC users were doing it. To change it back see Section 3.2.1. It also may change the date formats. Since you MUST use 4 digit years if any tests are entered for dates prior to 2000, and most DTRC databases go way back, some to the 80's, the program is likely to make changes.

7. The conversion (import) process involves some intense code execution, so it may take a while.
Appendix B
Glossary

Active Projects
When a project is completed it can be removed from the list of projects in the Project Number list. Projects which have not been removed are Active Projects.

Archiving Projects
The process of removing projects from the database and placing them in a different database is Archiving.

Break Lists
A list of specimens scheduled for break testing on a particular day is a Break List.

Cast Date
The Case Date is the sample was fabricated, and is the same as the Placement Date. Related terms are Placement Date, Sample Date, and Submitted Date.

Checkboxes
Field Test Data that is most appropriately represented by a box which can show a checkmark or be blank.

Client Import
The process of getting client data from an outside source, such as an Oracle or proprietary database.

CPR (Statistical Analysis)
GEOSYSTEM Software has a program for the statistical analysis of concrete (Concrete Performance Report, or CPR) which uses ACI 214 and other standards to produce statistical tables, graphs, and calculate required average strengths. QC-Concrete can export results to this program.

Custom Formats
Many licensees of the DTRC and QC-Concrete programs have non-standard features in their programs, typically. Custom Formats for their reports.

Data Import
Importing break data from a digital data acquisition system.

Field Data Table
The portion of the data entry screen between the test selection lists and the specimen table is the Field data Table.

Field or Data Field
The area on the screen where data is entered is a Data Field.

GDM
The GEOSYSTEM Data Manager is abbreviated GDM.

GEOSYSTEM Data Manager
The software used by GEOSYSTEM for Windows laboratory programs to manage project and test data is the GEOSYSTEM Data Manager, usually referred to as GDM.

Inactive Projects
When a project is completed it can be removed from the list of projects in the Project Number list. Projects which have been removed are Inactive Projects.

LD4
The GEOSYSTEM for Windows Drilling Log program, an alternative to GDM, is LD4.

PDF File
Report saved in the Adobe PDF (Portable Document Format) file format. Can be viewed as the original report using Adobe Acrobat Reader.

Placement Date
The Placement Date is the cement product was fabricated. Related terms are Sample Date, Cast Date, and Submitted Date.
Previewing
The process of displaying on the screen a report that can also be printed

Report Data
This is a peculiar term we are using to describe data that is on reports but rarely changes

Sample Date
The date the sample was taken is the Sample Data. Related terms are Placement Date, Cast Date, and Submitted Date.

Selecting Report
The process of choosing some Project Number and Test Number, and in some cases the Placement Date to uniquely identify a particular test is Selecting a Report

Shortcut Keys
Keystrokes which take the place of longer menu selections are Shortcut Keys.

Special Characters and Symbols
Special Characters and Symbols are for characters like fractions (¼) and the degree symbol (°).

Standard Formats
Any of the report formats which are supplied to all licensees of the software are Standard Formats.

Submitted Date
The Submitted Date is the date sample was delivered to the laboratory by others. Related terms are Placement Date, Cast Date, and Sample Date.

Test Standards
The ASTM, AASHTO, ACI, or UBC codes pertaining to a particular test are Test Standards

Testing Summary Reports
Reports with a few major results from a collection of tests, summarized in a table, are Testing Summary Reports
Appendix C
Upgrading to Ver. 2 from Ver. 1

C.1 Installation

Updating from version 1 to version 2 is done using the master version 2 CD. To do so, follow these steps:

1. Update to the most current release of version 1 of QC-Concrete. To do so go to WWW.GEOSYSTEMSOFTWARE.COM and click on the Program Updates / Concrete Break link. Follow the directions there. Then run QC-Concrete at least once after updating to insure that the update was successful, and any database changes have been incorporated.

2. Make a backup copy of the entire QC-Concrete program folder and if the database is located elsewhere, back it up as well. In the event of a failed update you will need the backup to be able to revert to the previous version. For example, one way to do this is:
   1) Double click on the "My Computer" Icon on the desktop.
   2) Navigate to the QC-Concrete program folder by opening the folders in its path in sequence.
   3) Right click on the QC-Concrete folder icon and select "Copy".
   4) Navigate to C:
   5) Right click and select "New" then "New Folder".
   6) Right click on the new folder (named "New Folder").
   7) Click on "Paste".
   8) If the database is not in the program folder, follow a similar procedure to back it up as well.

If you are unsure about these directions or how to copy a folder to make a backup, have your office computer expert do it for you.

3. Insert the new Version 2 CD in the computer where Version 1 is installed. If the setup program does not autostart, navigate to and run SETUP on the CD. The simplest way to do this is starting at the Windows Desktop, select Start, Run. Enter D:SETUP, select OK. D: is typical, if your CD-ROM drive is a different letter, use it.

4. Read the setup dialogs and do what they say. When you get to the Choose Destination Location dialog, it will suggest C:\Program Files\GEOSYS. If that is not your GEOSYSTEM for Windows folder, choose Browse, and navigate to the correct folder. If you do not have GEOSYSTEM for Windows installed, any new folder you choose will work.

5. When you get to the Select Program Manager Group dialog it will suggest GEOSYSTEM. This is where your QC-Concrete shortcut will be in your Start Menu. Select another program group if you would prefer.

6. While it is installing, please take a moment to complete the License Agreement and return it or a copy of it to us. If you completed a license agreement for version 1 you do not need to do so. If a license agreement was enclosed with the Version 2 CD, then we probably do not have a license on file and would appreciate it if you would send it.

7. When you get to the Installation Complete dialog, click Finish and you are done installing. Unless you are running Windows XP you should re-boot when suggested by the installer.
C.2 Running QC-Concrete for the First Time after Updating

You have a choice the first time it is run: You can immediately begin using this new version or you can work with the Demo database for awhile. We recommend you immediately begin using the new version, but offer you the choice. So, the first time the new program is run you will be given the option to update the database or use the demo. **One thing must be done in advance if you wish to use the demo database**, and your main database is in the program folder, you must move the main database somewhere else. Do that before you begin using the program if you wish to use the demo database before converting your main database to the new Version 2 format. Then you can move the main database back once you are ready to make the switch.

Once again, be sure you have made a backup copy of the database you are using, CQC-CP.MDB. Start the program as you normally did with the previous version. Using the start menu, choose Start, Programs, GEOSYSTEM, QC-Concrete (or other Program Group that you may have chosen) to run the program.

C.2.1 Database Choices

The following warning screen will appear:

![Update to Version 2 in Progress](image)

**Figure 76 - First program message after update to Ver. 2**

- **Cancel**: It is important to back up your database before converting it to Ver. 2, you made need to revert back to it if the update fails for some reason. If you need to back up your database, click **Cancel**. Refer to Section 9.8 for information about backing up your database.

- **No**: If you would like to work with the demo database and the new program before using your main database, select **No**. Your main database must not be in the program folder to have this option work. Move it to a different location before clicking **No**.

- **Yes**: To proceed with the database update click **Yes**.

C.2.2 Version 1 to Version 2 Database Update

If you selected Yes in the previous step, the program will display the message:
You can cancel the database update at this point, as you could at and for the reasons described in the previous step. When you click OK to proceed, the database and your screen layout forms (which are closely tied to the database structure) will be updated. The update progress is displayed on a screen like the following:

![Refresh Database](image)

**Figure 78 - Database Update Progress Display**

When both progress bars have reached 100%, click on OK and then restart the program. The program and database are now completely updated and ready to continue using. To familiarize yourself with the new features of the software, please read Section 2.1 of this manual.
Appendix D
Importing Break Machine Data

D.1 Load Machine Data Import

Some break machines are equipped with data logging equipment which can record break results. To be able to import those results into QC-Concrete contact GEOSYSTEM about whether the program's optional data import add-in supports your data acquisition system. Currently the only file formats which can be imported are from Admet (3 file formats), Advanced Machine Technology D 16 and Forney data acquisition systems.

When you have installed the data import add-in and are ready to import break results you should first enter new reports for each of the field tests which the specimens belong to. It is necessary that the specimen identifications be entered exactly as they will be entered on the the break machine. I.e. a specimen may be tagged as "0107577C". On the break machine keypad and in the report the specimen ID must be exactly "0107577C". You should also enter the specimen age and any known dimensions. If specimen numbers are not entered in the database before the import is done, the break data will not be imported.

During the import process QC-Concrete will keep a log of the results of its attempt to import each specimen. These are displayed in the table called "Merge Results". The term "Merge" refers to the process of reading data from one file and correctly placing it in the database, or merging it into the database. You can save these merge results to a file on your computer, or even print them out by clicking on "Save Merge Results". If you save them, the file they are saved to may either start fresh each time or be cumulative, appending the latest download to the previous download results. See below for information about this setup option. The merge results will state the result of the merge attempt for each record. The following are descriptions of these results:

- **Merged** - Data imported without problem
- **Break date mismatch, database showed 3/31/03 - merged anyway** - The break date found in the QC-Concrete database for the specimen being merged did not match the date in the merge file.
- **Load field contains data - not merged** - The specimen found in the QC-Concrete database contained a maximum load already. The user will need to determine if the existing load or the import file load is correct. It is likely in this case that the specimen ID in the import file is incorrect.
- **Specimen 0107577C not in database - not merged** - The specimen listed in the the import file was not found in the QC-Concrete database. It is likely in this case as well that the specimen ID in either the import file or QC-Concrete database is incorrect.

D.2 Initial Setup

Initial setup requires the selection of a few preferences. Select Tools>Import External Data then, on the form that follows, select "Setup".

- **Import File Format** - From the list of file formats select the one you are using.
  - **Admet - No job ID** is for Admet files where the header looks like this when you open the CSV file in Excel:
For this format, all of the SPEC ID#s must be unique in the entire QC-Concrete Break Table, so begin numbering specimens with 000001 and continue through 999999 (or higher if the Admet system allows more digits. This format is always saved as a comma separated value file.

- **Admet - With Job ID** is for Admet files where the header looks like this when you open the CSV file in Excel:

<table>
<thead>
<tr>
<th>DATE</th>
<th>TIME</th>
<th>SPEC#</th>
<th>SPEC TYPE</th>
<th>AREA (sqin)</th>
<th>LENGTH (in)</th>
<th>PEAK (Lb)</th>
<th>PEAK (psi)</th>
<th>CORR FACT</th>
<th>BREAK TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>3/17/2003</td>
<td>12:01:10</td>
<td>3001</td>
<td>12</td>
<td>125001</td>
<td>5182</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

For this format, all of the SPEC ID#s are combined with the JOB ID# to form a the unique specimen number in the QC-Concrete break table. So the first specimen number shown in the example would be specimen number 3001.5 in QC-Concrete. Be sure to remember the decimal point between the SPEC ID# and JOB ID# when entering the specimen numbers in QC-Concrete.

- **Admet - No Job ID, Tabbed** is for Admet files where the header looks like this when you open the LOG file in Notepad:

<table>
<thead>
<tr>
<th>DATE</th>
<th>TIME</th>
<th>SPEC#</th>
<th>SPEC TYPE</th>
<th>AREA (sqin)</th>
<th>LENGTH (in)</th>
<th>PEAK (Lb)</th>
<th>PEAK (psi)</th>
<th>CORR FACT</th>
<th>BREAK TYPE</th>
<th>AGE (days)</th>
<th>JOB ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>3/17/2003</td>
<td>12:01:10</td>
<td>3001</td>
<td>12</td>
<td>125001</td>
<td>5182</td>
<td>1</td>
<td>0</td>
<td>56</td>
<td>6</td>
</tr>
</tbody>
</table>

For this format, all of the SPEC ID#s must be unique in the entire QC-Concrete Break Table, so begin numbering specimens with 000001 and continue through 999999 (or higher if the Admet system allows more digits. This format is always has the LOG extension and is saved without using Excel.

- **AMT D16** is for Advanced Machine Technology files where the header looks like this when you open the file in Notepad:

<table>
<thead>
<tr>
<th>DATE</th>
<th>TIME</th>
<th>USER</th>
<th>ID#</th>
<th>Type</th>
<th>AREA (sqs)</th>
<th>Pk Load (Lb)</th>
<th>Pk Stress (psi)</th>
<th>LENGTH (in)</th>
<th>CORR FACT</th>
<th>Brk Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>2/1/2003</td>
<td>9:24:05</td>
<td>JLO</td>
<td>16093</td>
<td>CYL</td>
<td>28.274</td>
<td>124480</td>
<td>4480</td>
<td>12</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

For this format, all of the SPEC ID#s must be unique in the entire QC-Concrete Break Table, so begin numbering specimens with 000001 and continue through 999999 (or higher if the AMT D16 system allows more digits.

- **TestMark - Wincom - no Job ID** is for TestMark - Wincom files. This format is essentially the same as for Admet - no Job ID, so see above for description.
- **TestMark - Wincom - with Job ID** is for TestMark - Wincom files. This format is essentially the same as for Admet - with Job ID, so see above for description.

- **Forney** is for Forney files where the header looks like this when you open the CSV file in Excel:

  ![Microsoft Excel - ForneyTest.csv](image)

  - **Single step through the import process** - Checking this box causes the program to wait for you to press Next after each record is imported.
  - **“Save Merge results” appends ...** - Checking this box causes the program to add current merge results to an existing merge results log file. If this is not checked, clicking on “Save Merge results” will overwrite the existing results file. The merge results file is saved in the same folder as the data import source file. It is named "MergeResults.txt" and can be viewed using Notepad or any text/document editor.

**D.3 Before Importing a Break Data File**

All specimens that will be imported must already exist in a report in QC-Concrete. Create new reports as needed to enter all of the specimen's identification numbers before importing.

**D.4 Importing a Break Data File**

To import a break data file select Tools > Import External Data. In the Data Import Source frame click on "Select" and navigate to the folder where the data acquisition (D/A) file is. Then select from the list of files the one you are importing. Clicking, then click on "Import and Merge Data" starts the import process. If errors are encountered during the import and merge, a red error message will be displayed. The error will also be listed in the table of merge results.

**D.5 Tutorial**

Use one of the supplementary demo data files:

- Admet1.csv - example comma delimited
- Admet2.csv - example comma delimited with ID field at the end
- AMTD16Test - example Advanced Machine Technology
- ForneyTest - example Forney
They are supplied with the program for this tutorial.

1. Prepare the data acquisition demo by running the setup program, DATutorial.EXE, which is in your QC-Concrete program folder. When you run it you will be asked for the folder to install to, select the same QC-Concrete program folder. (i.e. C:\PROGRAM FILES\GEOSYS or Z:\CONCRETE\REPORTS, whatever the case may be).

2. Run QC-Concrete, select Tools>Administrator Tools and click "Browse for a new database location"

3. Locate the folder "DATutorial" in the QC-Concrete program folder and double-click on it to select it as the new database location. Click OK, then OK, then OK and the program will shutdown.

4. Admet & AMTD: Restart QC-Concrete and select Report Number 03001. There should be 12 specimens and no load, diameter, area, strength, etc.

Forney: Restart QC-Concrete and select Project Example1 and Report Number 1. There should be 4 specimens and load and strength only for the 7 day breaks.

5. Now for the import, click on Tools>Import external data. The Import External Data form will be shown.

6. Click on "Setup" and select an Import File Format for the tutorial,

   Admet & AMTD: Pick "Admet - No Job ID", "Admet - With Job ID", or "AMTD D16" (for the Advanced Machine Technology D16) then click "Close".

   Forney: Pick “Forney” then click enter.

7. Click on "Select" and select the drive or network location where the QC-Concrete program folder is, then navigate to and open the DATutorial folder, then click OK.

8. Admet & AMTD: Select the file Admet1.csv, Admet2.csv, or AMTD16Test depending on whether you are importing a "Admet - No Job ID", "Admet - With Job ID", or "AMTD D16" type of break file. (note that there is no data import example for the Admet tabbed file format.)

   Forney: Select the file ForneyTest.csv.

9. Click on "Import and Merge Data", after records are merged there should be a message that there were errors during the merge.

10. Scroll the Merge Results table to the right to show the status of each imported record. You will notice most are "Merged" but some list an error message.

11. Click on "Save merge results", and reply Yes to the option to print a copy. Click on close to end the data import session.

   Forney: Skip to 17.

12. Admet & AMTD: Observe now that some specimens in test 03001 have results.

13. On the printed summary of the merge, the first record lists a date mismatch error. Look at specimen 03001.6 or 03001F. The age was incorrectly entered in the database, but the results were merged anyway.

15. Notice that specimen 03003.4 or 03001D has a load but no other data. On the import log, record 5 was not imported because there was already a load entered. This is an example of what the program does if a specimen already has a load.

16. Finally, note on the printed summary of the merge that record 15 was not merged because there was no specimen 03008.7 or 03008G in the database.

Skip to last step

17. Forney: Take a look at project Example1 and report 1, the 28 day results are now entered.

18. On the printed summary of the merge note that record 15 was not merged because there was no specimen 62673 in the database. This illustrates an error where the specimen number is entered wrong at the break machine. There is a specimen 62973, in report number 6, and that is what should have been entered at the break machine.

19. Look now at record 18 on the printed summary of the merge. That record lists a date mismatch error. Look at report 9, the specimen was broken a day late, but the results were merged anyway.

20. Next look at record 22 where the log notes that the load field already contained data. In the Example1 project notice that report 11 has a load of 111111. On the import log, the record 22 load of 162915 was not imported. This is an example of what the program does if a specimen already has a load. The technician would need to figure out what to do with the 162915, hopefully with some success. In this case, the 111111 was inadvertently entered by another technician and needs to be manually replaced with 162915.

21. Finally, notice that record 35 says that specimen 700010 was not in the database. This is an example of what the program does if a specimen is not found. Again, it will take some detective work. In this case, the project and report had not been entered yet.

22. To repeat the tutorial, exit the program and copy the database from the DATutorial/Pristine folder to the DATutorial folder. That will restore the original, ready for D/A import demo database.
# Index

1 Column, 27

2 Column, 27

## A

Active Data Entry Fields, 17  
Adding Projects, 32  
Add-Ins, 81  
Addresses, 69  
Admet, 103  
Administrator tools, 79  
Adobe Acrobat, 71  
Advanced Machine Technology, 103  
Always replace, 74  
Always show this form before printing, 52  
Archived projects, 73  
Arranging the screen, 27  
Arranging the Screen, 28  
Automatic sizing of break table columns, 26  
Automatic specimen numbering, 80  
Automatically increment, 10  
Average Test Strength, 12  
Averaging strengths, 42

## B

Backing up the Database, 80  
Beams, 20  
Blue color title, 11  
Break list of all specimens, 23  
Break data table, 38  
Break list, 23, 58  
Break list report format, 23  
Break Table, 19  
Break Table Notes, 20  
Breaks  
adding, 38  
By counter, 10  
By project, 10

## C

Calculation component, 21  
Calculation result, 21  
Calculations, 41  
Checkbox group, 18  
Checkboxes, 18  
Colors, 24  
Concrete Performance Report, 77  
Confirm replace, 74  
Confirmation Prompts, 13

## D

Daily Test Report for Concrete, 91  
Data entry prompts, 17  
Data entry screen settings, 26  
Data logging equipment, 103  
Database location, 81  
Database Maintenance, 80  
Date fields, 37  
Date formats, 25  
Dates in Test Selection, 82  
Dates prior to Jan. 1, 2000, 25  
Default checkbox, 18  
Default Fracture Type, 13, 42  
Design Age field, 38  
Disable data entry for calculated fields, 26  
Distribution list, 22, 69  
Distribution List Options, 22  
Dropdown list, 42  
DTR, 91  
DTR2CQC.PRG, 91  
DTRC, 91  
Duplicate specimen warning, 12  
During data entry copy dates to blank date fields, 26

## E

E-mail, 71  
Entering Break Data, 39, 42  
Entering Break Data from a Break List, 42  
Entering Project Data, 34  
Envelopes, 53, 69  
Equation for calculation, 21  
Expert, 13  
Export text file - test summary, 66  
Export text file?, 52

## F

Fax, 71  
Features, 5  
Field data and break data, 35  
Field maps, 94  
Font options, 26  
Font subset, 26  
Forney, 103  
Fracture Type Menu, 42
G
General Options, 9
GEOSYSTEM Data Manager, 3

I
Identifying tests, 82
Import data, 91
Importing a GEOSYSTEM Data Manager project, 32
Importing break data, 103
Inactive project, 73
Include option to print envelopes following reports?, 52

J
Justification of the specimen numbers on reports, 15

L
Labels, 69
Last specimen number used, 80
LD4 Drilling Log Program, 3
Length of a field, 17
Limit to Project Number, 52
Local Settings, 9
Location of database, 81
Logo Sizing Checkbox, 21

M
Merging Branch Databases, 74
Mix information, 47
Mix Number, 38
Mix Reports, 48
Mix Tools, 48

N
Network Server, 1
Never replace, 74
New Features, 7
New Features with Version 2, 5
New Project, 32
New Test Status, 11
Number of Records, 80

O
Omit reports with specimens, 52
Omit reserve specimens, 52
Omit Reserves, 24
Other Report Printing Options, 52

P
PDF, 71
PDF Report Printing Options, 52
Peer to peer Network, 1
Percent of screen for start of second column, 27
Pick Report Template, 15
Placement date, 44
Preferences
   Options, 9
Prevent duplicate specimen numbers, 12
Preview, 54
Previewing, 51
Principle design age, 47
Print a report for each name on the distribution list?, 52
Printer Setup, 70
Printing, 51
Printing Test Reports, 53
Program in Use message, 13
Program in Use Warning, 79
Project data, 31
Project number, 44
Project Reports, 67
Project Template, 33
Properties for Break Table Field, 20
QuickData, 37

R
Renaming Projects, 82
Report data, 45, 56
Report data title, 84
Report Data Titles, 83
Report format, 13, 23
Report number, 44
Report Printing Sequence, 21
Report selection criteria, 51
Report Setup Tab, 13
Report with No Specimens, 13
Reporting Capabilities, 5
Reporting Compliance with Strength Specifications, 12
Resizing rows and columns, 40
Resizing tool buttons, 30
Retrieving a project, 74
Running the program after a program crash, 13

S
Selecting Projects, 31
Selecting report templates, 15
Selecting Test Reports, 51
Selecting tests, 36
Selecting Tests, 30
Selection fields, 27
Setup Distribution List Map, 22
Shortcut keys, 43
Shortcut to the layout menu, 28
Show or hide the break data section, 30
Show or hide the field test data section, 30
Sorting test numbers, 11
Special characters and symbols, 44
Specimen numbers unique in report, 12
Specimen Sort Order, 23
Specimen sorting, 23
Specimens in the database that were scheduled but skipped, 23
Specimens inadvertently tested early, 23
Specimens to be Included, 23
Standards title, 84
Standards Titles, 84
Statistical analysis, 77
Suggest the most likely value for first specimen number on a new report, 10
Summary report formats, 66

Selection Criteria, 62
Tests
Adding, 35
Editing, 35

Unique specimen numbers, 12
Updating from Version 1, 99

VPI, 91

Warning Colors, 39